summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-12-01 15:12:38 -0600
committerWilliam Hubbs <williamh@gentoo.org>2022-12-01 15:13:07 -0600
commit1dc05d35f986a5a3d96957221b46008ca00c069f (patch)
tree1cd2bfff8e4be2b48a3700d69921e69190b73f04 /dev-util
parentsci-visualization/gnuplot: add 5.4.5 (diff)
downloadgentoo-1dc05d35f986a5a3d96957221b46008ca00c069f.tar.gz
gentoo-1dc05d35f986a5a3d96957221b46008ca00c069f.tar.bz2
gentoo-1dc05d35f986a5a3d96957221b46008ca00c069f.zip
dev-util/github-cli: add 2.20.2
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/github-cli/Manifest2
-rw-r--r--dev-util/github-cli/github-cli-2.20.2.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-util/github-cli/Manifest b/dev-util/github-cli/Manifest
index 2860884c7156..c05c0babea21 100644
--- a/dev-util/github-cli/Manifest
+++ b/dev-util/github-cli/Manifest
@@ -2,3 +2,5 @@ DIST github-cli-2.14.3-deps.tar.xz 77143036 BLAKE2B 7f06905270a7c9b17bbe8a83353c
DIST github-cli-2.14.3.tar.gz 716098 BLAKE2B 7b45f97859501be4e639584e287d2114b9ed87402d3f35cc56eebdef8bf2b3cf8b9ecff633cf44a822edf20a5000c38a5b1c38822b0bf670d6c4c9c4e5e1a052 SHA512 460f3c053c1f0bea458f7a891f2b1a4cbd68b754bc165e3b097215748fc220f96138cf010608092702c86403d4551b288faba4349a69ae0e92b93ef4564825b5
DIST github-cli-2.18.0-deps.tar.xz 98885904 BLAKE2B 2ba1252ca1ddab0e0dda6dbbd6b262d19a701b6cb2a82420a29da5b08dab4369671f40adcdfb34760344d4d220bd91263cdefd7d57b92ce5770b2e682c6e4b44 SHA512 e9b1f87d4ec1c1e9d689df87c8a5d30180b0d60e074e292d262d0f204dc921bf09f13df8589892dccfde9ffd5579bd9c1c83169e36f6dc25b23ba3bfb2aa01be
DIST github-cli-2.18.0.tar.gz 738480 BLAKE2B c56adae59ddbfa6693dff569c265db615e9609f7fee9942c349cb202d64f44ea1e2cccdb89632e65ebb954e133939e54053933b77782c741d768742403975e65 SHA512 3522d42016b165a8ffa5620bd2352023affceabb26d6c14ba5f5eeb5f42e3cfc002c71e7f0c1acbf4d626f0c3588c1609255802aabd1f4f700875ada82ef6826
+DIST github-cli-2.20.2-deps.tar.xz 105896704 BLAKE2B c9562daa3dc682b4733d4a6b716556b13fc7329a46124f4cd1a0b2df9b8498d32801a97259a27645af643482d934a5968b237c48da4bcba2fe8ceda7d833e194 SHA512 81b1d7d7309a6abd0f9c2702345dc983816e835ed9058d140c717e5fc26352dc456d2bf63fc1bea3ca890c31e7173f3d3450939a3a58fff1b317b352bff0a885
+DIST github-cli-2.20.2.tar.gz 759883 BLAKE2B a227ffc039ce861b0e006679f5487c5d9016cb57fc90438e29cccfcce6b087534ca7f53858c492296f35d721b802639d8b0100cf9c04166162e2f207a35c856b SHA512 2e14c408c2fbf5a409e7a271b5c77400cc84cd7f2567722fe7140f685ecd297dd39062d02d3fafaf9fa396da419fb7aa0c2d93c0541a30f3286c6745c5965df4
diff --git a/dev-util/github-cli/github-cli-2.20.2.ebuild b/dev-util/github-cli/github-cli-2.20.2.ebuild
new file mode 100644
index 000000000000..834906664386
--- /dev/null
+++ b/dev-util/github-cli/github-cli-2.20.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit bash-completion-r1 flag-o-matic go-module
+
+DESCRIPTION="GitHub CLI"
+HOMEPAGE="https://github.com/cli/cli"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/cli/cli.git"
+else
+ SRC_URI="https://github.com/cli/cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv"
+ S="${WORKDIR}/cli-${PV}"
+fi
+
+LICENSE="MIT Apache-2.0 BSD BSD-2 MPL-2.0"
+SLOT="0"
+
+RDEPEND=">=dev-vcs/git-1.7.3"
+
+RESTRICT="test"
+
+src_unpack() {
+ if [[ ${PV} == *9999 ]]; then
+ git-r3_src_unpack
+ go-module_live_vendor
+ else
+ go-module_src_unpack
+ fi
+}
+
+src_compile() {
+ [[ ${PV} == *9999 ]] || export GH_VERSION="v${PV}"
+ # Filter '-flto*' flags to avoid build failures.
+ filter-flags "-flto*"
+ # Filter '-ggdb3' flag to avoid build failures. bugs.gentoo.org/847991
+ filter-flags "-ggdb3"
+ # Go LDFLAGS are not the same as GCC/Binutils LDFLAGS
+ unset LDFLAGS
+ # Once we set up cross compiling, this line will need to be adjusted
+ # to compile for the target.
+ # Everything else in this function happens on the host.
+ emake
+
+ einfo "Building man pages"
+ emake manpages
+
+ einfo "Building completions"
+ go run ./cmd/gh completion -s bash > gh.bash-completion || die
+ go run ./cmd/gh completion -s zsh > gh.zsh-completion || die
+}
+
+src_install() {
+ dobin bin/gh
+ dodoc README.md
+
+ doman share/man/man?/gh*.?
+
+ newbashcomp gh.bash-completion gh
+ insinto /usr/share/zsh/site-functions
+ newins gh.zsh-completion _gh
+}