summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-31 00:25:25 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-31 00:25:25 +0200
commit227c43f85e2ae65102e1e1dc79dd97e51815a9dd (patch)
treef8ddb6bd8b25f2ad7f8b66f3e8be871149a03a68 /dev-util
parentmedia-libs/libheif: bump to v1.8.0 (diff)
downloadgentoo-227c43f85e2ae65102e1e1dc79dd97e51815a9dd.tar.gz
gentoo-227c43f85e2ae65102e1e1dc79dd97e51815a9dd.tar.bz2
gentoo-227c43f85e2ae65102e1e1dc79dd97e51815a9dd.zip
dev-util/csup: Port to EAPI 7
Closes: https://bugs.gentoo.org/730700 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/csup/csup-20060318-r1.ebuild23
-rw-r--r--dev-util/csup/files/csup-20060318-respectflags.patch38
2 files changed, 32 insertions, 29 deletions
diff --git a/dev-util/csup/csup-20060318-r1.ebuild b/dev-util/csup/csup-20060318-r1.ebuild
index 2c033c7d93ef..109a7dc21dc3 100644
--- a/dev-util/csup/csup-20060318-r1.ebuild
+++ b/dev-util/csup/csup-20060318-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit toolchain-funcs eutils
+inherit toolchain-funcs
DESCRIPTION="A rewrite of CVSup"
HOMEPAGE="http://www.mu.org/~mux/csup.html"
@@ -13,31 +13,26 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-DEPEND="
+RDEPEND="
sys-libs/zlib:0=
dev-libs/openssl:0="
-
-RDEPEND="
- ${DEPEND}"
-
-DEPEND="
- ${DEPEND}
- >=sys-devel/bison-2.1"
+DEPEND="${RDEPEND}"
+BDEPEND=">=sys-devel/bison-2.1"
S="${WORKDIR}/${PN}"
-PATCHES=( "${FILESDIR}/${P}-respectflags.patch")
+PATCHES=( "${FILESDIR}"/${P}-respectflags.patch )
src_compile() {
# unable to work with yacc, but bison is ok.
emake \
CC="$(tc-getCC)" \
- PREFIX=/usr \
+ PREFIX="${EPREFIX}"/usr \
YACC=bison
}
src_install() {
- dobin "${PN}"
- doman "${PN}.1"
+ dobin csup
+ doman csup.1
einstalldocs
}
diff --git a/dev-util/csup/files/csup-20060318-respectflags.patch b/dev-util/csup/files/csup-20060318-respectflags.patch
index c95a974c75ed..541622df5777 100644
--- a/dev-util/csup/files/csup-20060318-respectflags.patch
+++ b/dev-util/csup/files/csup-20060318-respectflags.patch
@@ -1,22 +1,22 @@
-Index: csup/GNUmakefile
-===================================================================
---- csup.orig/GNUmakefile
-+++ csup/GNUmakefile
-@@ -21,7 +21,7 @@ WARNS= -Wall -W -Wno-unused-parameter -W
+--- a/GNUmakefile
++++ b/GNUmakefile
+@@ -21,22 +21,22 @@
-Wcast-align -Wunused-parameter -Wchar-subscripts -Winline \
-Wnested-externs -Wredundant-decls -Wno-format-y2k
-CFLAGS+= -g -O -pipe -DNDEBUG -I$(PREFIX)/include
-+CFLAGS+= -I$(PREFIX)/include
++CPPFLAGS+= -DNDEBUG -I$(PREFIX)/include
ifeq ($(UNAME), Linux)
- CFLAGS+= -D_XOPEN_SOURCE -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
+- CFLAGS+= -D_XOPEN_SOURCE -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
++ CPPFLAGS+= -D_XOPEN_SOURCE -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
endif
-@@ -29,14 +29,14 @@ ifeq ($(UNAME), Darwin)
- CFLAGS+= -DHAVE_FFLAGS
+ ifeq ($(UNAME), Darwin)
+- CFLAGS+= -DHAVE_FFLAGS
++ CPPFLAGS+= -DHAVE_FFLAGS
endif
CFLAGS+= $(WARNS)
-LDFLAGS= -L$(PREFIX)/lib -lcrypto -lz -lpthread
-+LIBS= -L$(PREFIX)/lib -lcrypto -lz -lpthread
++LIBS= -lcrypto -lz -lpthread
.PHONY: all clean install
@@ -28,11 +28,19 @@ Index: csup/GNUmakefile
config.c: parse.h
-Index: csup/Makefile
-===================================================================
---- csup.orig/Makefile
-+++ csup/Makefile
-@@ -11,7 +11,7 @@ SRCS= attrstack.c config.c detailer.c di
+@@ -49,9 +49,6 @@
+ clean:
+ rm -f csup $(OBJS) parse.c parse.h token.c csup.1.gz
+
+-%.o: %.c
+- $(CC) $(CFLAGS) -c -o $@ $<
+-
+ %.c: %.y
+ $(YACC) -d -o $@ $<
+
+--- a/Makefile
++++ b/Makefile
+@@ -11,7 +11,7 @@
globtree.c idcache.c keyword.c lister.c main.c misc.c mux.c parse.y \
pathcomp.c proto.c status.c stream.c threads.c token.l updater.c