summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-28 16:58:08 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:20:06 +0200
commit2a02aaae96aed2ee62bd493e8afbd7cfd9a21802 (patch)
tree0d42a0fa88b187facff82d7c82b3bbd6e9355937 /dev-util
parentdev-python/vcstools: add py3.8 (diff)
downloadgentoo-2a02aaae96aed2ee62bd493e8afbd7cfd9a21802.tar.gz
gentoo-2a02aaae96aed2ee62bd493e8afbd7cfd9a21802.tar.bz2
gentoo-2a02aaae96aed2ee62bd493e8afbd7cfd9a21802.zip
dev-util/wstool: add py3.8
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/wstool/wstool-0.1.18.ebuild8
-rw-r--r--dev-util/wstool/wstool-9999.ebuild8
2 files changed, 10 insertions, 6 deletions
diff --git a/dev-util/wstool/wstool-0.1.18.ebuild b/dev-util/wstool/wstool-0.1.18.ebuild
index 41972a54bea4..3a75c3bd2270 100644
--- a/dev-util/wstool/wstool-0.1.18.ebuild
+++ b/dev-util/wstool/wstool-0.1.18.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-PYTHON_COMPAT=( python{3_6,3_7} )
+EAPI=7
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -34,7 +34,6 @@ RDEPEND="
>=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
- dev-python/sphinx
test? (
dev-python/nose[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
@@ -44,6 +43,9 @@ DEPEND="${RDEPEND}
dev-vcs/subversion
)
"
+BDEPEND="
+ dev-python/sphinx
+"
DISTUTILS_IN_SOURCE_BUILD="yes"
diff --git a/dev-util/wstool/wstool-9999.ebuild b/dev-util/wstool/wstool-9999.ebuild
index 41972a54bea4..3a75c3bd2270 100644
--- a/dev-util/wstool/wstool-9999.ebuild
+++ b/dev-util/wstool/wstool-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-PYTHON_COMPAT=( python{3_6,3_7} )
+EAPI=7
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -34,7 +34,6 @@ RDEPEND="
>=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
- dev-python/sphinx
test? (
dev-python/nose[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
@@ -44,6 +43,9 @@ DEPEND="${RDEPEND}
dev-vcs/subversion
)
"
+BDEPEND="
+ dev-python/sphinx
+"
DISTUTILS_IN_SOURCE_BUILD="yes"