summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2016-03-29 09:34:23 +0200
committerFabian Groffen <grobian@gentoo.org>2016-03-29 09:35:09 +0200
commit2cac81d1c5f6a7881a1e13e4c2ff50f00727cc0d (patch)
tree42da798958f82c6bd7d7d4b36978e3fd6a904992 /dev-util
parentdev-util/uncrustify: version bump to 0.62, bug #578418 (diff)
downloadgentoo-2cac81d1c5f6a7881a1e13e4c2ff50f00727cc0d.tar.gz
gentoo-2cac81d1c5f6a7881a1e13e4c2ff50f00727cc0d.tar.bz2
gentoo-2cac81d1c5f6a7881a1e13e4c2ff50f00727cc0d.zip
dev-util/uncrustify: fix live ebuild
Package-Manager: portage-2.2.28-prefix
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/uncrustify/uncrustify-0.62.ebuild14
-rw-r--r--dev-util/uncrustify/uncrustify-9999.ebuild20
2 files changed, 24 insertions, 10 deletions
diff --git a/dev-util/uncrustify/uncrustify-0.62.ebuild b/dev-util/uncrustify/uncrustify-0.62.ebuild
index c8a91bb17f51..9de89d8f4c74 100644
--- a/dev-util/uncrustify/uncrustify-0.62.ebuild
+++ b/dev-util/uncrustify/uncrustify-0.62.ebuild
@@ -1,18 +1,19 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
if [[ $PV == *9999* ]]; then
EGIT_REPO_URI="git://github.com/uncrustify/uncrustify.git
https://github.com/uncrustify/uncrustify.git"
KEYWORDS=""
SRC_URI=""
- inherit git-r3
+ inherit git-r3 autotools
else
KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
SRC_URI="https://github.com/uncrustify/${PN}/archive/${P}.tar.gz"
+ S=${WORKDIR}/uncrustify-${P}
fi
PYTHON_COMPAT=( python2_7 )
@@ -28,7 +29,12 @@ IUSE="test"
DEPEND="test? ( ${PYTHON_DEPS} )"
-S=${WORKDIR}/uncrustify-${P}
+src_prepare() {
+ if [[ ${PV} == *9999* ]] ; then
+ eautoreconf
+ fi
+ default
+}
python_test() {
cd tests
diff --git a/dev-util/uncrustify/uncrustify-9999.ebuild b/dev-util/uncrustify/uncrustify-9999.ebuild
index cf696e3ae8b0..9de89d8f4c74 100644
--- a/dev-util/uncrustify/uncrustify-9999.ebuild
+++ b/dev-util/uncrustify/uncrustify-9999.ebuild
@@ -1,18 +1,19 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
if [[ $PV == *9999* ]]; then
- EGIT_REPO_URI="git://github.com/bengardner/uncrustify.git
- https://github.com/bengardner/uncrustify.git"
+ EGIT_REPO_URI="git://github.com/uncrustify/uncrustify.git
+ https://github.com/uncrustify/uncrustify.git"
KEYWORDS=""
SRC_URI=""
- inherit git-r3
+ inherit git-r3 autotools
else
KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
- SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ SRC_URI="https://github.com/uncrustify/${PN}/archive/${P}.tar.gz"
+ S=${WORKDIR}/uncrustify-${P}
fi
PYTHON_COMPAT=( python2_7 )
@@ -28,6 +29,13 @@ IUSE="test"
DEPEND="test? ( ${PYTHON_DEPS} )"
+src_prepare() {
+ if [[ ${PV} == *9999* ]] ; then
+ eautoreconf
+ fi
+ default
+}
+
python_test() {
cd tests
${EPYTHON} run_tests.py || die "tests failed"