summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-23 10:31:52 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-23 10:44:52 +0100
commit2eea25efd90d77eff2d6d56d6c9944097e78d615 (patch)
tree66c6eb9020d5a615779859d11f7889365daa3eb2 /dev-util
parentdev-util/catkin: remove old (diff)
downloadgentoo-2eea25efd90d77eff2d6d56d6c9944097e78d615.tar.gz
gentoo-2eea25efd90d77eff2d6d56d6c9944097e78d615.tar.bz2
gentoo-2eea25efd90d77eff2d6d56d6c9944097e78d615.zip
dev-util/catkin: Add pypy support.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/catkin/catkin-0.7.6.ebuild3
-rw-r--r--dev-util/catkin/catkin-9999.ebuild3
-rw-r--r--dev-util/catkin/files/sitedir.patch15
3 files changed, 19 insertions, 2 deletions
diff --git a/dev-util/catkin/catkin-0.7.6.ebuild b/dev-util/catkin/catkin-0.7.6.ebuild
index 206cc518143a..2bce0e1b502d 100644
--- a/dev-util/catkin/catkin-0.7.6.ebuild
+++ b/dev-util/catkin/catkin-0.7.6.ebuild
@@ -10,7 +10,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
EGIT_REPO_URI="https://github.com/ros/catkin"
fi
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
inherit ${SCM} cmake-utils python-r1 python-utils-r1
@@ -43,6 +43,7 @@ PATCHES=(
"${FILESDIR}/catkin_prefix_path_util_py.patch"
"${FILESDIR}/package_xml.patch"
"${FILESDIR}/etc.patch"
+ "${FILESDIR}/sitedir.patch"
)
src_prepare() {
diff --git a/dev-util/catkin/catkin-9999.ebuild b/dev-util/catkin/catkin-9999.ebuild
index 206cc518143a..2bce0e1b502d 100644
--- a/dev-util/catkin/catkin-9999.ebuild
+++ b/dev-util/catkin/catkin-9999.ebuild
@@ -10,7 +10,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
EGIT_REPO_URI="https://github.com/ros/catkin"
fi
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
inherit ${SCM} cmake-utils python-r1 python-utils-r1
@@ -43,6 +43,7 @@ PATCHES=(
"${FILESDIR}/catkin_prefix_path_util_py.patch"
"${FILESDIR}/package_xml.patch"
"${FILESDIR}/etc.patch"
+ "${FILESDIR}/sitedir.patch"
)
src_prepare() {
diff --git a/dev-util/catkin/files/sitedir.patch b/dev-util/catkin/files/sitedir.patch
new file mode 100644
index 000000000000..61fcad29d04a
--- /dev/null
+++ b/dev-util/catkin/files/sitedir.patch
@@ -0,0 +1,15 @@
+Pass --install-lib to setup.py install.
+pypy installs in /usr/site-packages otherwise...
+
+Index: catkin-0.7.6/cmake/templates/python_distutils_install.sh.in
+===================================================================
+--- catkin-0.7.6.orig/cmake/templates/python_distutils_install.sh.in
++++ catkin-0.7.6/cmake/templates/python_distutils_install.sh.in
+@@ -30,4 +30,6 @@ echo_and_run /usr/bin/env \
+ build --build-base "@CMAKE_CURRENT_BINARY_DIR@" \
+ install \
+ $DESTDIR_ARG \
+- @SETUPTOOLS_ARG_EXTRA@ --prefix="@CMAKE_INSTALL_PREFIX@" --install-scripts="${PYTHON_SCRIPTDIR:-@CMAKE_INSTALL_PREFIX@/@CATKIN_GLOBAL_BIN_DESTINATION@}"
++ @SETUPTOOLS_ARG_EXTRA@ --prefix="@CMAKE_INSTALL_PREFIX@" \
++ --install-scripts="${PYTHON_SCRIPTDIR:-@CMAKE_INSTALL_PREFIX@/@CATKIN_GLOBAL_BIN_DESTINATION@}" \
++ --install-lib="@CMAKE_INSTALL_PREFIX@/@PYTHON_INSTALL_DIR@"