summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2023-01-25 22:08:50 +0100
committerArsen Arsenović <arsen@gentoo.org>2023-01-25 22:08:50 +0100
commit3ce0b50014fbe5def9dd5f420c1d08e1dfb7da7d (patch)
tree50e448eba7697edeba0fc2699515382852daf78f /dev-util
parentdev-vcs/python-gitlab: drop 3.10.0 (diff)
downloadgentoo-3ce0b50014fbe5def9dd5f420c1d08e1dfb7da7d.tar.gz
gentoo-3ce0b50014fbe5def9dd5f420c1d08e1dfb7da7d.tar.bz2
gentoo-3ce0b50014fbe5def9dd5f420c1d08e1dfb7da7d.zip
dev-util/poke: add 3.0
Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/poke/Manifest1
-rw-r--r--dev-util/poke/poke-3.0.ebuild126
2 files changed, 127 insertions, 0 deletions
diff --git a/dev-util/poke/Manifest b/dev-util/poke/Manifest
index e91559e35719..9066d7c932cc 100644
--- a/dev-util/poke/Manifest
+++ b/dev-util/poke/Manifest
@@ -1,2 +1,3 @@
DIST poke-2.4.tar.gz 7372092 BLAKE2B 64b8b22713bb581c30b624200c0a283a8de548895db2c21d83babbb18a93f3a8975dd7af752bd7ea856242f90035add249fbb62462ac632bec351598bcca0fe5 SHA512 6fa1097a5cbbd4171b6a390934c5648b4c382b8b8c8dd4955bba82cb57107f67e23b39f2df2081904a02f457e6c5b2d10baed710da3ed4b9b9eab3f4127e12bc
DIST poke-2.90.1.tar.gz 7512925 BLAKE2B 38c9283f1c0b183b1b74c2ebd347edf6e9a9191d19070f7da32e6b0f520ec8197be3a813bc98160b47363cd11069bdaf84bb528498fe51cf2dcadf0bfa06a25e SHA512 f5823bed61ab64c2cdde83c918716fe64ad5552499023b2f5202130d6b2bab405c9d1cb1e12c7f190749689d86bf36f4edfe140ce748ac4c5f03d219197558d3
+DIST poke-3.0.tar.gz 7510801 BLAKE2B 4e80bd0603b0f690f7b6dc9b3913bb165f61160cd6e677751e6f8ea444bc395141204cc32c3ed97bad4b4044d505a800a64a4c973200e7338b50f05d9ea90c25 SHA512 5b786cdfae732a1f7196b0c4bf271c97f204f8fe9de9b34d92704f35150c8abfc2c080940d67efac63e3e82d0d4afe2fde4b75066faf9f4d1e9df6b6f62edb96
diff --git a/dev-util/poke/poke-3.0.ebuild b/dev-util/poke/poke-3.0.ebuild
new file mode 100644
index 000000000000..80e149428e9b
--- /dev/null
+++ b/dev-util/poke/poke-3.0.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common flag-o-matic toolchain-funcs
+
+DESCRIPTION="Extensible editor for structured binary data"
+HOMEPAGE="https://www.jemarch.net/poke"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/poke.git"
+ REGEN_BDEPEND="
+ >=sys-devel/autoconf-2.62
+ >=sys-devel/automake-1.16
+ sys-apps/gawk
+ sys-apps/help2man
+ sys-apps/texinfo
+ sys-devel/bison
+ sys-devel/flex
+ "
+elif [[ $(ver_cut 2) -ge 90 || $(ver_cut 3) -ge 90 ]]; then
+ SRC_URI="https://alpha.gnu.org/gnu/poke/${P}.tar.gz"
+ REGEN_BDEPEND=""
+else
+ SRC_URI="mirror://gnu/poke/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ REGEN_BDEPEND=""
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="emacs pvm-profiling nbd nls test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/boehm-gc:=
+ dev-libs/libatomic_ops
+ sys-devel/gettext
+ sys-libs/readline:=
+ emacs? ( >=app-editors/emacs-23.1:* )
+ nbd? ( sys-libs/libnbd )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( nbd? ( sys-libs/libnbd[uri-support] ) )
+"
+BDEPEND="
+ ${REGEN_BDEPEND}
+ virtual/pkgconfig
+ pvm-profiling? ( sys-devel/gcc )
+ emacs? ( >=app-editors/emacs-23.1:* )
+ test? (
+ dev-util/dejagnu
+ nbd? ( sys-block/nbdkit )
+ )
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+pkg_pretend() {
+ if use pvm-profiling && ! tc-is-gcc; then
+ die "USE=pvm-profiling requires GCC"
+ fi
+}
+
+pkg_setup() {
+ use emacs && elisp-check-emacs-version
+}
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == 9999 ]]; then
+ ./bootstrap || die
+ fi
+}
+
+src_configure() {
+ # See bug 858461.
+ # Upstream support might happen one day. For context, only one file needs
+ # LTO to be disabled (since it's an autogenerated bytecode interpreter),
+ # others do not. The build system will handle this at some point in the
+ # future. Until then, just filter out LTO.
+ filter-lto
+
+ local myconf=(
+ --with-lispdir="${EPREFIX}/${SITELISP}/${PN}"
+ --enable-hserver
+ $(use_enable nbd libnbd)
+ $(use_enable pvm-profiling)
+ $(use_enable nls)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+
+ if use emacs; then
+ cd etc || die
+ elisp-compile *.el
+ fi
+}
+
+src_install() {
+ default
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ cd etc || die
+ elisp-install "${PN}" *.el *.elc
+ fi
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}