summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2016-08-09 14:29:59 -0700
committerBrian Dolbec <dolsen@gentoo.org>2016-08-09 16:47:21 -0700
commit3f1a63db0564b4a83587801bee3a3fee66f9fb85 (patch)
treecda4efda79c060c446b692cdf4152bb26c8fde6b /dev-util
parentprofiles/base/package.use.mask: Mask doc use flag due to missing dep (diff)
downloadgentoo-3f1a63db0564b4a83587801bee3a3fee66f9fb85.tar.gz
gentoo-3f1a63db0564b4a83587801bee3a3fee66f9fb85.tar.bz2
gentoo-3f1a63db0564b4a83587801bee3a3fee66f9fb85.zip
dev-util/buildbot-pkg: New buildbot-0.9 pkg
This package is used for the various buildbot-www base and plugins. Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/buildbot-pkg/Manifest1
-rw-r--r--dev-util/buildbot-pkg/buildbot-pkg-0.9.0_rc1.ebuild44
-rw-r--r--dev-util/buildbot-pkg/metadata.xml32
3 files changed, 77 insertions, 0 deletions
diff --git a/dev-util/buildbot-pkg/Manifest b/dev-util/buildbot-pkg/Manifest
new file mode 100644
index 000000000000..8c0d8256b93b
--- /dev/null
+++ b/dev-util/buildbot-pkg/Manifest
@@ -0,0 +1 @@
+DIST buildbot-pkg-0.9.0rc1.tar.gz 3363 SHA256 0bbbf10361087493cc6ee62e077863eafe1b3e24c43a8429a6eb1a75b35359b6 SHA512 b9bf46252ddb28f1d83f4425f65cd8cdc187eaaee0006ec84d3bf9fe89d32001295ff631fa2f4f29d61a0da3ea9ab89e5b95a402bbd781b537e3f1497fa1ec23 WHIRLPOOL 33d643cae5ec89d418ec3a41c3903a8d8c1f6a95626a8391a4ffde3872184e5d8cfb776affe392cd70f6500267be08f972e4e92c9360029f9880b887e4c78cd5
diff --git a/dev-util/buildbot-pkg/buildbot-pkg-0.9.0_rc1.ebuild b/dev-util/buildbot-pkg/buildbot-pkg-0.9.0_rc1.ebuild
new file mode 100644
index 000000000000..9900daaa60a7
--- /dev/null
+++ b/dev-util/buildbot-pkg/buildbot-pkg-0.9.0_rc1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 )
+
+EGIT_REPO_URI="git://github.com/buildbot/buildbot.git"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit distutils-r1
+
+MY_PV="${PV/_p/p}"
+MY_V="0.9.0rc1"
+MY_P="${PN}-${MY_V}"
+
+DESCRIPTION="BuildBot common www build tools for packaging releases"
+HOMEPAGE="http://trac.buildbot.net/ https://github.com/buildbot/buildbot http://pypi.python.org/pypi/buildbot"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ =dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+"
+
+S=${WORKDIR}/${MY_P}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}
diff --git a/dev-util/buildbot-pkg/metadata.xml b/dev-util/buildbot-pkg/metadata.xml
new file mode 100644
index 000000000000..5a7ed409ddf0
--- /dev/null
+++ b/dev-util/buildbot-pkg/metadata.xml
@@ -0,0 +1,32 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ <name>Brian Dolbec</name>
+ </maintainer>
+ <longdescription lang="en">The BuildBot is a system to automate the compile/test cycle required
+ by most software projects to validate code changes.
+ Features:
+ * run builds on a variety of slave platforms
+ * arbitrary build process: handles projects using C, Python, whatever
+ * minimal host requirements: python and Twisted
+ * slaves can be behind a firewall if they can still do checkout
+ * status delivery through web page, email, IRC, other protocols
+ * track builds in progress, provide estimated completion time
+ * flexible configuration by subclassing generic build process classes
+ * debug tools to force a new build, submit fake Changes, query slave
+ status
+ * released under the GPL</longdescription>
+ <upstream>
+ <maintainer>
+ <email>devel@buildbot.net</email>
+ <name>Developers List</name>
+ </maintainer>
+ <remote-id type="pypi">buildbot</remote-id>
+ </upstream>
+</pkgmetadata>