summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-14 18:22:19 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-14 19:10:16 -0400
commit6087ef400265ab5a85bff365e0ba370a55da8e47 (patch)
tree8bdb515fe831a7a589bd7b72566a6a6c3547d618 /dev-util
parentdev-embedded/arduino-builder: update SRC_URI (diff)
downloadgentoo-6087ef400265ab5a85bff365e0ba370a55da8e47.tar.gz
gentoo-6087ef400265ab5a85bff365e0ba370a55da8e47.tar.bz2
gentoo-6087ef400265ab5a85bff365e0ba370a55da8e47.zip
Revert "Revert "dev-util/mingw64-toolchain: filter ssp for cross mingw""
This reverts commit d06a9cf2f29ca13694007493173a9ebe304005de. This turned out to be fine, was misled that it may have leaked to gcc's own libraries rather than just mingw's crt. Still require filtering ssp on every mingw packages though, strip-unsupported-flags can't pickup that this will fail with a basic `int main(void) { return 0; }` compiler test. Closes: https://bugs.gentoo.org/870136 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0-r1.ebuild1
-rw-r--r--dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0_p1.ebuild1
2 files changed, 2 insertions, 0 deletions
diff --git a/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0-r1.ebuild b/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0-r1.ebuild
index 0bfc818d9698..59a0022ee10b 100644
--- a/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0-r1.ebuild
+++ b/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0-r1.ebuild
@@ -187,6 +187,7 @@ src_compile() {
# cross-compiling, cleanup and let ./configure handle it
unset AR AS CC CPP CXX LD NM OBJCOPY OBJDUMP RANLIB RC STRIP
CHOST=${CTARGET}
+ filter-flags '-fstack-protector*' #870136
filter-flags '-fuse-ld=*'
strip-unsupported-flags
mwt-build "${@:2}"
diff --git a/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0_p1.ebuild b/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0_p1.ebuild
index 3b878de762bf..4ad2c7cf514f 100644
--- a/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0_p1.ebuild
+++ b/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0_p1.ebuild
@@ -188,6 +188,7 @@ src_compile() {
# cross-compiling, cleanup and let ./configure handle it
unset AR AS CC CPP CXX LD NM OBJCOPY OBJDUMP RANLIB RC STRIP
CHOST=${CTARGET}
+ filter-flags '-fstack-protector*' #870136
filter-flags '-fuse-ld=*'
strip-unsupported-flags
mwt-build "${@:2}"