summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-15 13:09:36 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-15 13:26:04 +0100
commit62196f91dee81427159763cfb098964c9a3be672 (patch)
treef8dfe25c78e5ff611f222dfb30ad6c3206fae0ae /dev-util
parentmail-mta/postfix: bump to 3.7_pre20211113 (diff)
downloadgentoo-62196f91dee81427159763cfb098964c9a3be672.tar.gz
gentoo-62196f91dee81427159763cfb098964c9a3be672.tar.bz2
gentoo-62196f91dee81427159763cfb098964c9a3be672.zip
dev-util/pkgcheck: Extend permitted uid/gid range
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pkgcheck/pkgcheck-0.10.8-r1.ebuild (renamed from dev-util/pkgcheck/pkgcheck-0.10.8.ebuild)8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-util/pkgcheck/pkgcheck-0.10.8.ebuild b/dev-util/pkgcheck/pkgcheck-0.10.8-r1.ebuild
index 25466d114146..b2d246af149e 100644
--- a/dev-util/pkgcheck/pkgcheck-0.10.8.ebuild
+++ b/dev-util/pkgcheck/pkgcheck-0.10.8-r1.ebuild
@@ -47,6 +47,14 @@ BDEPEND="
distutils_enable_tests setup.py
+src_prepare() {
+ # extend allowed system uid/gid range per Council 2021-11-14
+ sed -i -e 's:500:750:g' \
+ src/pkgcheck/checks/acct.py \
+ tests/checks/test_acct.py || die
+ distutils-r1_src_prepare
+}
+
src_test() {
local -x PYTHONDONTWRITEBYTECODE=
distutils-r1_src_test