summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-30 09:09:56 +0100
committerSam James <sam@gentoo.org>2023-05-01 00:49:12 +0100
commit7e725757dfb1309aa2d4924d52f1e7f826cfacfa (patch)
tree87375492179f8978ba89d270808e7f48af5f32e3 /dev-util
parentdev-libs/json-glib: conditionally build tests (diff)
downloadgentoo-7e725757dfb1309aa2d4924d52f1e7f826cfacfa.tar.gz
gentoo-7e725757dfb1309aa2d4924d52f1e7f826cfacfa.tar.bz2
gentoo-7e725757dfb1309aa2d4924d52f1e7f826cfacfa.zip
dev-util/libabigail: make assertions optional; don't attempt to use valgrind in tests
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/libabigail/libabigail-2.3-r2.ebuild (renamed from dev-util/libabigail/libabigail-2.3-r1.ebuild)5
-rw-r--r--dev-util/libabigail/libabigail-9999.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-util/libabigail/libabigail-2.3-r1.ebuild b/dev-util/libabigail/libabigail-2.3-r2.ebuild
index d65ee49694bc..9dca18088bcc 100644
--- a/dev-util/libabigail/libabigail-2.3-r1.ebuild
+++ b/dev-util/libabigail/libabigail-2.3-r2.ebuild
@@ -36,7 +36,7 @@ fi
LICENSE="Apache-2.0-with-LLVM-exceptions"
SLOT="0/2"
-IUSE="btf ${LIBABIGAIL_DOCS_USEFLAG} test"
+IUSE="btf debug ${LIBABIGAIL_DOCS_USEFLAG} test"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -71,8 +71,11 @@ my_src_configure() {
--disable-rpm415
--disable-ctf
--disable-debug-ct-propagation
+ # Don't try to run Valgrind on tests.
+ --disable-valgrind
--enable-bash-completion
--enable-python3
+ $(use_enable debug assert)
$(use_enable btf)
$(use_enable doc apidoc)
$(use_enable doc manual)
diff --git a/dev-util/libabigail/libabigail-9999.ebuild b/dev-util/libabigail/libabigail-9999.ebuild
index d65ee49694bc..9dca18088bcc 100644
--- a/dev-util/libabigail/libabigail-9999.ebuild
+++ b/dev-util/libabigail/libabigail-9999.ebuild
@@ -36,7 +36,7 @@ fi
LICENSE="Apache-2.0-with-LLVM-exceptions"
SLOT="0/2"
-IUSE="btf ${LIBABIGAIL_DOCS_USEFLAG} test"
+IUSE="btf debug ${LIBABIGAIL_DOCS_USEFLAG} test"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -71,8 +71,11 @@ my_src_configure() {
--disable-rpm415
--disable-ctf
--disable-debug-ct-propagation
+ # Don't try to run Valgrind on tests.
+ --disable-valgrind
--enable-bash-completion
--enable-python3
+ $(use_enable debug assert)
$(use_enable btf)
$(use_enable doc apidoc)
$(use_enable doc manual)