summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-12 05:58:07 +0000
committerSam James <sam@gentoo.org>2023-02-12 05:59:03 +0000
commit7ea79fe232bccc971ae3540c0ccb1e61e4cdfe1c (patch)
tree592c7ae12b9facf40e12a2509406df8e5d47c450 /dev-util
parentdev-util/diffoscope: drop 234 (diff)
downloadgentoo-7ea79fe232bccc971ae3540c0ccb1e61e4cdfe1c.tar.gz
gentoo-7ea79fe232bccc971ae3540c0ccb1e61e4cdfe1c.tar.bz2
gentoo-7ea79fe232bccc971ae3540c0ccb1e61e4cdfe1c.zip
dev-util/fq: add 0.3.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/fq/Manifest2
-rw-r--r--dev-util/fq/fq-0.3.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/fq/Manifest b/dev-util/fq/Manifest
index 6b80aede94a9..1ea2601a2ca0 100644
--- a/dev-util/fq/Manifest
+++ b/dev-util/fq/Manifest
@@ -1,2 +1,4 @@
DIST fq-0.2.0-deps.tar.xz 23494148 BLAKE2B 59400200a814d08fac88d9bcedc5db0ea2ae5192a5a67b389fa62cbb6e82d8f4210e9153a14aa2e259143c68f67863865359e7636966419f47b00f9fb44394ca SHA512 fa8d3464976569c5bca810dcbce6492bce85173907366aeda3a290a467d027891a8edc889283a9185c5d7139d51f77a2fb9f08b5a452ebc9cd96994f7db8127e
DIST fq-0.2.0.tar.gz 12762736 BLAKE2B 7f1496b1da231b804b7e3af40f252381e83c62ca5e4779af65a502e9dc6a15a0a5267af68b83569c996f726870234c03952711e8262f360b2061bf34df5b2e4e SHA512 faf88faf0121a837c32dfbfe4c9e05261f28c2eec50d981f7840937ad121e45b0fa6809f428c45c0b41c99d1ae12a667a81911943e0601f2d81922ac670e03fe
+DIST fq-0.3.0-deps.tar.xz 23500960 BLAKE2B ed03e21c6ad2bedad72c68018518394b6438791d88edf14a725c56752fd83003e486d5e2d9e139742683b1adc43d8931b9a99f06e68d0c4abb389f20de0e1969 SHA512 1ca347a8b057948880fc049ac51810acd8212df5a74410bdeb1fba9f470369cf377f185d1fb36fa603bcaa7aeb0c25e50389935223a4f6a1786f919421933ec2
+DIST fq-0.3.0.tar.gz 12772624 BLAKE2B 07fb3109b89ca3c1a77210d0d59930c4a5665a0dc256d3daf6727d96fedd5fc3ac151b1623a5354cef96e21a0009023702759edd50712a4e76554b6cff71618d SHA512 725b9e7fc3fd481af1d792dcdb37a42d2cf0bb634b424df801909208c2479493219d08649e943296dd187f27f3ff1f16779f1ec3318e6eb99c9fe13943c5e9ae
diff --git a/dev-util/fq/fq-0.3.0.ebuild b/dev-util/fq/fq-0.3.0.ebuild
new file mode 100644
index 000000000000..5df96c3f076c
--- /dev/null
+++ b/dev-util/fq/fq-0.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Tool for working with binary data (app-misc/jq for binary formats)"
+HOMEPAGE="https://github.com/wader/fq"
+SRC_URI="https://github.com/wader/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-tcltk/expect )"
+
+src_prepare() {
+ default
+
+ # Don't unconditionally (and therefore twice) build tests
+ # TODO: upstream
+ sed -i -e 's/all: test fq/all: fq/' Makefile || die
+}
+
+src_compile() {
+ # Avoid -s being set in Makefile (stripping)
+ export GO_BUILD_LDFLAGS="-w"
+
+ default
+}
+
+src_install() {
+ einstalldocs
+
+ dobin fq
+}