summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-09 17:38:49 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-09 18:46:01 +0100
commit851539d05ba74c25e5f79826eb2f0a65a3a6a45f (patch)
tree18956fbca9d216a2e7814dd747f3eec1fb09226a /dev-util
parentdev-python/catkin_pkg: Add pypy/3 support. (diff)
downloadgentoo-851539d05ba74c25e5f79826eb2f0a65a3a6a45f.tar.gz
gentoo-851539d05ba74c25e5f79826eb2f0a65a3a6a45f.tar.bz2
gentoo-851539d05ba74c25e5f79826eb2f0a65a3a6a45f.zip
dev-util/catkin: remove old
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/catkin/Manifest2
-rw-r--r--dev-util/catkin/catkin-0.7.1-r2.ebuild110
-rw-r--r--dev-util/catkin/catkin-0.7.2.ebuild110
3 files changed, 0 insertions, 222 deletions
diff --git a/dev-util/catkin/Manifest b/dev-util/catkin/Manifest
index dff4f787ea26..0491695b6d39 100644
--- a/dev-util/catkin/Manifest
+++ b/dev-util/catkin/Manifest
@@ -1,3 +1 @@
-DIST catkin-0.7.1.tar.gz 200307 SHA256 232cc85807daee31329ba4509fb1e5697ddb0a17f9442ac886a5883da687d9ab SHA512 e1ab220dc04e9522059c073c328c7da9d957266d2030e07a4ae03829c5666abf8ff5008e8208b5ca4b9a0153cb201337879e3c8f987d84fe5a4b66000d60ae03 WHIRLPOOL f47fb5a51869f49fc238eeb05ae76284081d8ac522283232b182197d7fc8e0255f34e99fd7f08abc79427f63e554e0cefdf5bee81a96a64d9ef489c45151af52
-DIST catkin-0.7.2.tar.gz 201049 SHA256 e8c23823b8cc6ea19b5e15af93c2790395cae72b82797c8f1ce2569e0c036e2f SHA512 23587533d531f6ef2fdc4c109a7954a771af60b95261057061aca50bf6d041e31307f4429d6dc9021ecc9e21d723806278b186a037b7ac26b751d83cb842ea37 WHIRLPOOL f91c4164ace4a354fcb9541ddd54f310b3bd5e3f481b0bf9c02cf594531485b079ec026ce6ce388cabf54a7bbc91230ddc71aa07a567a23d1b3384b7e0a313f0
DIST catkin-0.7.4.tar.gz 201140 SHA256 e113577697cd58432111c187b3faaa0df365f7694fe81ff71f9d29b65d467e48 SHA512 89bd38e8fbe4eba481404295f83a77974a2af14a038d326b294029d84789356290480588d7824e4e9849a9974a8ca08be13115c459aa6e00a8e36ce861f46a83 WHIRLPOOL 66b738d02609d9cfe891f7e159ec8ff980acb18208b635d25e9c66895e85ebd6024082ff117d3c1e0a26ebe529d7079aea2f8ecdfa541dc449b0ea768e033dd0
diff --git a/dev-util/catkin/catkin-0.7.1-r2.ebuild b/dev-util/catkin/catkin-0.7.1-r2.ebuild
deleted file mode 100644
index ada4a5e9254e..000000000000
--- a/dev-util/catkin/catkin-0.7.1-r2.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/ros/catkin"
-fi
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit ${SCM} cmake-utils python-r1 python-utils-r1
-
-DESCRIPTION="Cmake macros and associated python code used to build some parts of ROS"
-HOMEPAGE="http://wiki.ros.org/catkin"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="https://github.com/ros/catkin/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-
-RDEPEND="
- dev-python/catkin_pkg[${PYTHON_USEDEP}]
- dev-python/empy[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] dev-python/mock[${PYTHON_USEDEP}] )"
-
-PATCHES=(
- "${FILESDIR}/tests.patch"
- "${FILESDIR}/distutils.patch"
- "${FILESDIR}/catkin_prefix_path.patch"
- "${FILESDIR}/gnuinstalldirs.patch"
- "${FILESDIR}/catkin_prefix_path_util_py.patch"
- "${FILESDIR}/package_xml.patch"
-)
-
-src_prepare() {
- # fix libdir
- sed -i \
- -e 's:LIBEXEC_DESTINATION lib:LIBEXEC_DESTINATION libexec:' \
- -e 's:}/lib:}/${CMAKE_INSTALL_LIBDIR}:' \
- -e 's:DESTINATION lib):DESTINATION ${CMAKE_INSTALL_LIBDIR}):' \
- -e 's:DESTINATION lib/:DESTINATION ${CMAKE_INSTALL_LIBDIR}/:' \
- -e 's:PYTHON_INSTALL_DIR lib:PYTHON_INSTALL_DIR ${CMAKE_INSTALL_LIBDIR}:' \
- cmake/*.cmake || die
- cmake-utils_src_prepare
-}
-
-catkin_src_configure_internal() {
- mycmakeargs+=( -DPYTHON_EXECUTABLE="${PYTHON}" )
- python_export PYTHON_SCRIPTDIR
- cmake-utils_src_configure
-}
-
-src_configure() {
- local mycmakeargs=(
- "$(cmake-utils_use test CATKIN_ENABLE_TESTING)"
- "-DCATKIN_BUILD_BINARY_PACKAGE=ON"
- )
- python_foreach_impl catkin_src_configure_internal
-}
-
-src_compile() {
- python_foreach_impl cmake-utils_src_compile
-}
-
-src_test() {
- unset PYTHON_SCRIPTDIR
- python_foreach_impl cmake-utils_src_test
-}
-
-catkin_src_install_internal() {
- python_export PYTHON_SCRIPTDIR
- cmake-utils_src_install
- if [ ! -f "${T}/.catkin_python_symlinks_generated" ]; then
- dodir /usr/bin
- for i in "${D}/${PYTHON_SCRIPTDIR}"/* ; do
- dosym ../lib/python-exec/python-exec2 "/usr/bin/${i##*/}" || die
- done
- touch "${T}/.catkin_python_symlinks_generated"
- fi
-}
-
-src_install() {
- python_foreach_impl catkin_src_install_internal
-
- doenvd "${FILESDIR}/40catkin"
-
- # needed to be considered as a workspace
- touch "${ED}/usr/.catkin"
-}
-
-pkg_postinst() {
- ewarn "Starting from version 0.7.1-r2, dev-util/catkin changed the"
- ewarn "installation path for package.xml files on Gentoo."
- ewarn "In order for ROS to work properly, you will need to reinstall ROS"
- ewarn "packages that have it installed in the old location:"
- ewarn " emerge -1O /usr/share/*/package.xml"
- ewarn "See https://bugs.gentoo.org/show_bug.cgi?id=595004 for more details."
-}
diff --git a/dev-util/catkin/catkin-0.7.2.ebuild b/dev-util/catkin/catkin-0.7.2.ebuild
deleted file mode 100644
index ada4a5e9254e..000000000000
--- a/dev-util/catkin/catkin-0.7.2.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/ros/catkin"
-fi
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit ${SCM} cmake-utils python-r1 python-utils-r1
-
-DESCRIPTION="Cmake macros and associated python code used to build some parts of ROS"
-HOMEPAGE="http://wiki.ros.org/catkin"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="https://github.com/ros/catkin/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-
-RDEPEND="
- dev-python/catkin_pkg[${PYTHON_USEDEP}]
- dev-python/empy[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] dev-python/mock[${PYTHON_USEDEP}] )"
-
-PATCHES=(
- "${FILESDIR}/tests.patch"
- "${FILESDIR}/distutils.patch"
- "${FILESDIR}/catkin_prefix_path.patch"
- "${FILESDIR}/gnuinstalldirs.patch"
- "${FILESDIR}/catkin_prefix_path_util_py.patch"
- "${FILESDIR}/package_xml.patch"
-)
-
-src_prepare() {
- # fix libdir
- sed -i \
- -e 's:LIBEXEC_DESTINATION lib:LIBEXEC_DESTINATION libexec:' \
- -e 's:}/lib:}/${CMAKE_INSTALL_LIBDIR}:' \
- -e 's:DESTINATION lib):DESTINATION ${CMAKE_INSTALL_LIBDIR}):' \
- -e 's:DESTINATION lib/:DESTINATION ${CMAKE_INSTALL_LIBDIR}/:' \
- -e 's:PYTHON_INSTALL_DIR lib:PYTHON_INSTALL_DIR ${CMAKE_INSTALL_LIBDIR}:' \
- cmake/*.cmake || die
- cmake-utils_src_prepare
-}
-
-catkin_src_configure_internal() {
- mycmakeargs+=( -DPYTHON_EXECUTABLE="${PYTHON}" )
- python_export PYTHON_SCRIPTDIR
- cmake-utils_src_configure
-}
-
-src_configure() {
- local mycmakeargs=(
- "$(cmake-utils_use test CATKIN_ENABLE_TESTING)"
- "-DCATKIN_BUILD_BINARY_PACKAGE=ON"
- )
- python_foreach_impl catkin_src_configure_internal
-}
-
-src_compile() {
- python_foreach_impl cmake-utils_src_compile
-}
-
-src_test() {
- unset PYTHON_SCRIPTDIR
- python_foreach_impl cmake-utils_src_test
-}
-
-catkin_src_install_internal() {
- python_export PYTHON_SCRIPTDIR
- cmake-utils_src_install
- if [ ! -f "${T}/.catkin_python_symlinks_generated" ]; then
- dodir /usr/bin
- for i in "${D}/${PYTHON_SCRIPTDIR}"/* ; do
- dosym ../lib/python-exec/python-exec2 "/usr/bin/${i##*/}" || die
- done
- touch "${T}/.catkin_python_symlinks_generated"
- fi
-}
-
-src_install() {
- python_foreach_impl catkin_src_install_internal
-
- doenvd "${FILESDIR}/40catkin"
-
- # needed to be considered as a workspace
- touch "${ED}/usr/.catkin"
-}
-
-pkg_postinst() {
- ewarn "Starting from version 0.7.1-r2, dev-util/catkin changed the"
- ewarn "installation path for package.xml files on Gentoo."
- ewarn "In order for ROS to work properly, you will need to reinstall ROS"
- ewarn "packages that have it installed in the old location:"
- ewarn " emerge -1O /usr/share/*/package.xml"
- ewarn "See https://bugs.gentoo.org/show_bug.cgi?id=595004 for more details."
-}