summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-08 08:14:26 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-08 08:14:26 +0200
commit9985eb2bfefb4c77f2f56d1c468cc3ea2f9e2969 (patch)
tree532ee7658682b07ed12be5abbafc22d56e636e25 /dev-util
parentdev-python/PyGithub: Drop old (diff)
downloadgentoo-9985eb2bfefb4c77f2f56d1c468cc3ea2f9e2969.tar.gz
gentoo-9985eb2bfefb4c77f2f56d1c468cc3ea2f9e2969.tar.bz2
gentoo-9985eb2bfefb4c77f2f56d1c468cc3ea2f9e2969.zip
dev-util/debugedit: Drop old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/debugedit/debugedit-4.14.2-r1.ebuild92
-rw-r--r--dev-util/debugedit/files/debugedit-4.14.2-no-reorder.patch57
2 files changed, 0 insertions, 149 deletions
diff --git a/dev-util/debugedit/debugedit-4.14.2-r1.ebuild b/dev-util/debugedit/debugedit-4.14.2-r1.ebuild
deleted file mode 100644
index ad6b532ec6c8..000000000000
--- a/dev-util/debugedit/debugedit-4.14.2-r1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic
-
-MY_P=rpm-${PV}
-DESCRIPTION="Stand-alone debugedit from RPM"
-HOMEPAGE="http://www.rpm.org
- https://github.com/rpm-software-management/rpm"
-SRC_URI="http://ftp.rpm.org/releases/rpm-$(ver_cut 1-2).x/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2+ LGPL-2+"
-SLOT="0"
-KEYWORDS="amd64 hppa ~ia64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="
- sys-libs/zlib:=
- >=dev-libs/popt-1.7
- dev-libs/elfutils
- dev-libs/nss
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- # do not reorder sections, ever; otherwise it breaks gcc
- # https://bugs.gentoo.org/666954
- eapply "${FILESDIR}"/debugedit-4.14.2-no-reorder.patch
- eapply_user
-
- # cheat it into believing we're bundling db
- mkdir -p db/dist || die
- touch db/dist/configure || die
- chmod +x db/dist/configure || die
- echo 'install:' > db3/Makefile || die
-
- # TODO: why do we need to do this?
- mkdir rpm || die
- find -name '*.h' -exec cp {} rpm/ ';' || die
-}
-
-src_configure() {
- append-cppflags -I"${EPREFIX}/usr/include/nss" -I"${EPREFIX}/usr/include/nspr"
- local myconf=(
- # force linking to static librpmio
- --disable-shared
-
- # disable linking compression libraries
- ac_cv_header_bzlib_h=no
- ac_cv_header_lzma_h=no
- --disable-zstd
-
- # fake some libraries we don't use
- ac_cv_header_magic_h=yes
- ac_cv_lib_magic_magic_open=yes
-
- # use nss as crypto provider
- --with-crypto=nss
-
- # disable other stuff irrelevant to debugedit
- --disable-nls
- --disable-python
- --without-acl
- --without-archive
- --without-cap
- --without-external-db
- --without-hackingdocs
- --without-lua
- --without-selinux
- )
- econf "${myconf[@]}"
-}
-
-src_compile() {
- emake -C misc
- emake -C rpmio
- emake debugedit
-}
-
-src_test() {
- :
-}
-
-src_install() {
- dobin debugedit
-}
diff --git a/dev-util/debugedit/files/debugedit-4.14.2-no-reorder.patch b/dev-util/debugedit/files/debugedit-4.14.2-no-reorder.patch
deleted file mode 100644
index 0c196a842b4c..000000000000
--- a/dev-util/debugedit/files/debugedit-4.14.2-no-reorder.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From 0779d60cb5941610dd1f31632aa1655bf2cc447a Mon Sep 17 00:00:00 2001
-From: Sergei Trofimovich <slyfox@gentoo.org>
-Date: Sat, 6 Oct 2018 17:56:00 +0100
-Subject: [PATCH] debugedit: don't reorder sections
-
-In https://bugs.gentoo.org/666954 debugedit processed
-crtbeginS.o from gcc-8.2.0 and turned into invalid ELF:
-
-```
-$ cp crtbeginS-ok-7.3.0.o.back crtbeginS-ok-7.3.0.o
-$ debugedit -i -b $(pwd) -d /usr/src/debug -l ./foo crtbeginS-ok-7.3.0.o
-$ export LANG=C
-$ readelf -a crtbeginS-ok-7.3.0.o.back >/dev/null && echo ok
-readelf: Warning: [ 9]: Info field (8) should index a relocatable section.
-ok
-
-$ readelf -a crtbeginS-ok-7.3.0.o >/dev/null && echo ok
-readelf: Warning: [ 9]: Info field (8) should index a relocatable section.
-readelf: Error: bad symbol index: 54495f00 in reloc
-readelf: Error: bad symbol index: 656c6261 in reloc
-readelf: Error: bad symbol index: 62615465 in reloc
-readelf: Error: bad symbol index: 69665f61 in reloc
-readelf: Warning: local symbol 11 found at index >= symtab's sh_info value of 11
-readelf: Warning: local symbol 14 found at index >= symtab's sh_info value of 11
-readelf: Warning: local symbol 15 found at index >= symtab's sh_info value of 11
-```
-
-Ths fix is not to reorder sections as debugedit does not
-account for offset change.
-
-debugedit already does it for final executables and shared libraries.
-
-Bug: https://bugs.gentoo.org/666954
-Closes: https://github.com/rpm-software-management/rpm/issues/423
-Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
----
- tools/debugedit.c | 7 +++----
- 1 file changed, 3 insertions(+), 4 deletions(-)
-
-diff --git a/tools/debugedit.c b/tools/debugedit.c
-index 84568dd29..a723283c0 100644
---- a/tools/debugedit.c
-+++ b/tools/debugedit.c
-@@ -2347,10 +2347,9 @@ fdopen_dso (int fd, const char *name)
- goto error_out;
- }
-
-- /* If there are phdrs we want to maintain the layout of the
-- allocated sections in the file. */
-- if (phnum != 0)
-- elf_flagelf (elf, ELF_C_SET, ELF_F_LAYOUT);
-+ /* We maintain the layout of the allocated sections in the file:
-+ https://github.com/rpm-software-management/rpm/issues/423 */
-+ elf_flagelf (elf, ELF_C_SET, ELF_F_LAYOUT);
-
- memset (dso, 0, sizeof(DSO));
- dso->elf = elf;