summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-09-19 11:30:17 -0700
committerMatt Turner <mattst88@gentoo.org>2020-09-19 11:31:23 -0700
commitc29052d0f72ee95e3f62eef794505f788009d947 (patch)
tree26725d7a6ec767a8c89f614fc851c54db43ac5ad /dev-util
parentapp-emulation/hercules: port to EAPI 7 (diff)
downloadgentoo-c29052d0f72ee95e3f62eef794505f788009d947.tar.gz
gentoo-c29052d0f72ee95e3f62eef794505f788009d947.tar.bz2
gentoo-c29052d0f72ee95e3f62eef794505f788009d947.zip
dev-util/catalyst: Version bump to 3.0.13
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/catalyst/Manifest1
-rw-r--r--dev-util/catalyst/catalyst-3.0.13.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-util/catalyst/Manifest b/dev-util/catalyst/Manifest
index a550f90a9b7f..d6da9ead53b9 100644
--- a/dev-util/catalyst/Manifest
+++ b/dev-util/catalyst/Manifest
@@ -1,2 +1,3 @@
DIST catalyst-3.0.12.tar.bz2 621114 BLAKE2B 52306fb90f2ea3856ea26e436b4c520cc8ec65e22542ecd2ed20a54306655ea0eb3b607749fa42e6871256644e46e903b18d3159979ad40b95fc8ea1c05a1fbb SHA512 8bb50375ff8549ef790e2999ba71607281a6f631c7adec976f7e31302e8d16eaab41795d97474285e1506068117570fe350d77e4881169ae8051371bb8d54fda
+DIST catalyst-3.0.13.tar.bz2 621326 BLAKE2B f87a94b696d897fad8cab5e033a68a944dd5f73cbb110c3051432f9ae8baf8d341e456e1c9935345ac9102e99301c912abe706225023b3bdf28372095410cb26 SHA512 87f66b56056000ebee061003ae08d6e4e6b64aadbe89d71f6d50fe86e838e04d3f534dd3bc2f561fe42762de4108bf4d5536fab485fa260c251f90b45e97e8a9
DIST catalyst-3.0.9.tar.bz2 873866 BLAKE2B 293a4d52c57e73269f1f82fed8ea72934a0f939b3b9d4fb9943f4971fd4155edecc6cf0170b917eba16f0125aac9861041b7e10f85f6110a35659a2f85fd3665 SHA512 c8c25ad1c76b0040bd84b491909d364306746c660afbbb8c6a074911779aabe89b60a12cc3ac5b9cd3398bdf8986b50d24d9979c3d12d2fa9de66ebf62ded309
diff --git a/dev-util/catalyst/catalyst-3.0.13.ebuild b/dev-util/catalyst/catalyst-3.0.13.ebuild
new file mode 100644
index 000000000000..644bdda69629
--- /dev/null
+++ b/dev-util/catalyst/catalyst-3.0.13.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == *9999* ]]; then
+ SRC_ECLASS="git-r3"
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/catalyst.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/catalyst.git/snapshot/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1 ${SRC_ECLASS}
+
+DESCRIPTION="Release metatool used for creating releases based on Gentoo Linux"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Catalyst"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="ccache doc +iso kernel_linux system-bootloader"
+
+DEPEND="
+ app-text/asciidoc
+ >=dev-python/snakeoil-0.6.5[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/snakeoil-0.6.5[${PYTHON_USEDEP}]
+ >=dev-python/pydecomp-0.3[${PYTHON_USEDEP}]
+ app-arch/lbzip2
+ app-crypt/shash
+ sys-fs/dosfstools
+ !kernel_FreeBSD? ( || ( app-arch/tar[xattr] app-arch/libarchive[xattr] ) )
+ kernel_FreeBSD? ( app-arch/libarchive[xattr] )
+ amd64? ( >=sys-boot/syslinux-3.72 )
+ x86? ( >=sys-boot/syslinux-3.72 )
+ ccache? ( dev-util/ccache )
+ iso? ( virtual/cdrtools )
+ kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )
+"
+PDEPEND="system-bootloader? ( >=sys-apps/memtest86+-5.01-r4
+ sys-boot/grub:2
+ amd64? ( sys-boot/grub[grub_platforms_efi-32,grub_platforms_efi-64] )
+ x86? ( sys-boot/grub[grub_platforms_efi-32] )
+ sys-boot/syslinux
+ sys-boot/shim )"
+
+python_prepare_all() {
+ python_setup
+ echo VERSION="${PV}" "${PYTHON}" setup.py set_version
+ VERSION="${PV}" "${PYTHON}" setup.py set_version || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # build the man pages and docs
+ emake
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use doc; then
+ dodoc files/HOWTO.html files/docbook-xsl.css
+ fi
+}