summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-12-12 15:00:29 +0100
committerPatrice Clement <monsieurp@gentoo.org>2020-12-12 15:03:26 +0100
commitcc08bbd83727a0f702610a30e2e2c782b2fe3687 (patch)
tree8ebe15e32ef70f8900d27a390cb2bae035cf0ab7 /dev-util
parentdev-util/dwdiff: add missing die. (diff)
downloadgentoo-cc08bbd83727a0f702610a30e2e2c782b2fe3687.tar.gz
gentoo-cc08bbd83727a0f702610a30e2e2c782b2fe3687.tar.bz2
gentoo-cc08bbd83727a0f702610a30e2e2c782b2fe3687.zip
dev-util/dwdiff: fix booleans redefinition.
Courtesy of Soap. Closes: https://bugs.gentoo.org/759382 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/dwdiff/dwdiff-2.1.2.ebuild2
-rw-r--r--dev-util/dwdiff/files/C99-fix.patch15
2 files changed, 16 insertions, 1 deletions
diff --git a/dev-util/dwdiff/dwdiff-2.1.2.ebuild b/dev-util/dwdiff/dwdiff-2.1.2.ebuild
index 01a0d81ab2ae..5c70c554fffb 100644
--- a/dev-util/dwdiff/dwdiff-2.1.2.ebuild
+++ b/dev-util/dwdiff/dwdiff-2.1.2.ebuild
@@ -25,7 +25,7 @@ DEPEND="
nls? ( sys-devel/gettext )"
PATCHES=(
-
+ "${FILESDIR}/C99-fix.patch"
)
src_prepare() {
diff --git a/dev-util/dwdiff/files/C99-fix.patch b/dev-util/dwdiff/files/C99-fix.patch
new file mode 100644
index 000000000000..9d6d9ae2bca5
--- /dev/null
+++ b/dev-util/dwdiff/files/C99-fix.patch
@@ -0,0 +1,15 @@
+--- a/src/definitions.h
++++ b/src/definitions.h
+@@ -43,11 +43,11 @@
+
+ /*==== Misc definitions ====*/
+ /* Define a bool type if not already defined (C++ and C99 do)*/
+-#if !(defined(__cplusplus) || (defined(__STDC_VERSION__) && __STDC_VERSION__ >= 19990601L))
++#if !(defined(__cplusplus) || (defined(__STDC_VERSION__) && __STDC_VERSION__ >= 199901L))
+ /*@-incondefs@*/
+ typedef enum {false, true} bool;
+ /*@+incondefs@*/
+-#elif defined(__STDC_VERSION__) && __STDC_VERSION__ >= 19990601L
++#elif defined(__STDC_VERSION__) && __STDC_VERSION__ >= 199901L
+ #include <stdbool.h>
+ #endif