summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-10-22 22:34:12 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-10-22 22:34:50 +0100
commitcdaef6215a0e08b65c966a6a56c74baea9f6583f (patch)
tree8d77b02b79d512ee3d4b77db9cb49d6bba266c12 /dev-util
parentwww-servers/nginx: bump to v1.17.5 (diff)
downloadgentoo-cdaef6215a0e08b65c966a6a56c74baea9f6583f.tar.gz
gentoo-cdaef6215a0e08b65c966a6a56c74baea9f6583f.tar.bz2
gentoo-cdaef6215a0e08b65c966a6a56c74baea9f6583f.zip
dev-util/ccache: bump up to 3.7.5
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ccache/Manifest1
-rw-r--r--dev-util/ccache/ccache-3.7.5.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/dev-util/ccache/Manifest b/dev-util/ccache/Manifest
index 9a0c645c2fad..d35ddae67ad0 100644
--- a/dev-util/ccache/Manifest
+++ b/dev-util/ccache/Manifest
@@ -2,3 +2,4 @@ DIST ccache-3.7.1.tar.xz 349276 BLAKE2B 4f36ccb378b614668777d8be32dd343a0e59e368
DIST ccache-3.7.2.tar.xz 351168 BLAKE2B 6e5c8847f961bd5aa2cf325e582ece9e8bfb9c015fe3dcb01c8ca1e1834fdfb82a351ec49e203721486817df58c6aebf28e0af011f470fb739d5016f72191654 SHA512 3290f0609c27a2f063e632392be01ef163273115700f87a6d2954fcfd52fcc14bf66fc147ecbd2b692258317e113bf8be9f7efdf377560e2e8d9dd67cef58147
DIST ccache-3.7.3.tar.xz 351416 BLAKE2B f825eea87e89246edecbbc0b02cd0f67bbb0e9eb082a4f0c3d9aadca14a20e2d8e9af5f2c067d78393ea92c11878a11423402160210f3f79a3135d345225e0ad SHA512 74e6dd9558273af74aaf085d932955e8ded3d9f7d7b316172109af8f703f00a75fcc27187469d9cb5ba8654bcad12e406bede77cfcacbc0a752d5ca42e52c628
DIST ccache-3.7.4.tar.xz 351576 BLAKE2B fa2a9c051ff3f9c0550c6301e8d6c9e0eb7ac68687a30a6e8c1ee794ecd6b62925fdc940d493a9fb22d9094c5f2a0f3b2788c6291430ca532661ea6ddef45456 SHA512 cc382f37f7efb30a64f6fc2b136ef7424fe51795a778dbb18dde7c9e80636515f242f51c3ef3231f74d154e65ed9e815abf8241eb1a8f4e0b4fe4f533ea27146
+DIST ccache-3.7.5.tar.xz 352440 BLAKE2B 6761d7a1a8c8086081fa46d50db1dce719856910da6324c9863a3f3731fdb0f5153e0d93a5c575074d1993650623e4e4b02d83dd3b656a31cb9be04ad6b58efa SHA512 d66eb9d923c3e4663242a034860bd198175e08274a295b6d5d94e6cd69fe32afa3fb8c228d64d5c5dda025e6f97d0aef0586ce4dbd66e8ce3a23093331f1841f
diff --git a/dev-util/ccache/ccache-3.7.5.ebuild b/dev-util/ccache/ccache-3.7.5.ebuild
new file mode 100644
index 000000000000..998d395a3b2d
--- /dev/null
+++ b/dev-util/ccache/ccache-3.7.5.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="fast compiler cache"
+HOMEPAGE="https://ccache.dev/"
+SRC_URI="https://github.com/ccache/ccache/releases/download/v${PV}/ccache-${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+
+DEPEND="app-arch/xz-utils
+ sys-libs/zlib"
+RDEPEND="${DEPEND}
+ dev-util/shadowman
+ sys-apps/gentoo-functions"
+# clang-specific tests use it to compare objects for equality.
+# Let's pull in the dependency unconditionally.
+DEPEND+="
+ test? ( dev-libs/elfutils )"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.5-nvcc-test.patch
+)
+
+src_prepare() {
+ default
+
+ # make sure we always use system zlib
+ rm -rf src/zlib || die
+ sed \
+ -e "/^EPREFIX=/s:'':'${EPREFIX}':" \
+ "${FILESDIR}"/ccache-config-3 > ccache-config || die
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_test() {
+ emake check V=1
+}
+
+src_install() {
+ DOCS=( doc/{AUTHORS,MANUAL,NEWS}.adoc CONTRIBUTING.md README.md )
+ default
+
+ dobin ccache-config
+ insinto /usr/share/shadowman/tools
+ newins - ccache <<<'/usr/lib/ccache/bin'
+
+ DOC_CONTENTS="
+To use ccache with **non-Portage** C compiling, add
+'${EPREFIX}/usr/lib/ccache/bin' to the beginning of your path, before
+'${EPREFIX}/usr/bin'. Portage will automatically take advantage of ccache with
+no additional steps. If this is your first install of ccache, type
+something like this to set a maximum cache size of 2GB:\\n
+# ccache -M 2G\\n
+If you are upgrading from an older version than 3.x you should clear all of your caches like so:\\n
+# CCACHE_DIR='${CCACHE_DIR:-${PORTAGE_TMPDIR}/ccache}' ccache -C\\n
+ccache now supports sys-devel/clang and dev-lang/icc, too!"
+
+ readme.gentoo_create_doc
+}
+
+pkg_prerm() {
+ if [[ -z ${REPLACED_BY_VERSION} && ${ROOT:-/} == / ]] ; then
+ eselect compiler-shadow remove ccache
+ fi
+}
+
+pkg_postinst() {
+ if [[ ${ROOT:-/} == / ]]; then
+ eselect compiler-shadow update ccache
+ fi
+
+ # nuke broken symlinks from previous versions that shouldn't exist
+ rm -rf "${EROOT}"/usr/lib/ccache.backup || die
+
+ readme.gentoo_print_elog
+}