summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-02-05 12:24:27 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-02-05 12:28:32 +0100
commitd1126590f92e4fe49c6e03dbb37df948cac457c0 (patch)
tree5ef28cd3ac654b6184a8136e44ae9bd123273c57 /dev-util
parentgames-emulation/ppsspp: bump to 1.17.1 (diff)
downloadgentoo-d1126590f92e4fe49c6e03dbb37df948cac457c0.tar.gz
gentoo-d1126590f92e4fe49c6e03dbb37df948cac457c0.tar.bz2
gentoo-d1126590f92e4fe49c6e03dbb37df948cac457c0.zip
dev-util/wasm3: new package; add 0.5.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/wasm3/Manifest1
-rw-r--r--dev-util/wasm3/metadata.xml13
-rw-r--r--dev-util/wasm3/wasm3-0.5.0.ebuild39
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-util/wasm3/Manifest b/dev-util/wasm3/Manifest
new file mode 100644
index 000000000000..ebb17b046c3a
--- /dev/null
+++ b/dev-util/wasm3/Manifest
@@ -0,0 +1 @@
+DIST wasm3-0.5.0.tar.gz 2582080 BLAKE2B 5ae9fd2aa295cec6a737fa6a56f35ce85a5443dc7b517b019a14bfc30110f3eec7a2421c31905c980694e5017ec6852450c7773e92d4f67fd7af4d41f1de84ed SHA512 87d29f942ef9a93faeb4085f1fc7ae8c274a7bd528ccaaf56a273815c524e43c96635acd6b59ee607d5d0c383c1d1358d09080a0d1a23cf1dcaedcab6c56d39e
diff --git a/dev-util/wasm3/metadata.xml b/dev-util/wasm3/metadata.xml
new file mode 100644
index 000000000000..30cd34ad07ab
--- /dev/null
+++ b/dev-util/wasm3/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/wasm3/wasm3/issues/</bugs-to>
+ <remote-id type="github">wasm3/wasm3</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/wasm3/wasm3-0.5.0.ebuild b/dev-util/wasm3/wasm3-0.5.0.ebuild
new file mode 100644
index 000000000000..316033c51925
--- /dev/null
+++ b/dev-util/wasm3/wasm3-0.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A fast WebAssembly interpreter and the most universal WASM runtime"
+HOMEPAGE="https://github.com/wasm3/wasm3/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DOCS=( README.md docs )
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DBUILD_WASI=simple
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ dobin "${BUILD_DIR}/wasm3"
+
+ einstalldocs
+}