summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-04-26 16:12:46 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-04-26 16:13:12 +0100
commite2bdd86afcb2a5c3a390fbecf7ee2a4a6de5e26d (patch)
treebd6e98d1e1a78ceb4df13f8d12adb020ecad8e82 /dev-util
parentnet-misc/dhcpcd: Removed old. (diff)
downloadgentoo-e2bdd86afcb2a5c3a390fbecf7ee2a4a6de5e26d.tar.gz
gentoo-e2bdd86afcb2a5c3a390fbecf7ee2a4a6de5e26d.tar.bz2
gentoo-e2bdd86afcb2a5c3a390fbecf7ee2a4a6de5e26d.zip
dev-util/ccache: bump up to 3.7
Notable changes: - home page is moved to ccache.dev - releases moved to github See https://github.com/ccache/ccache/issues/396 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ccache/Manifest1
-rw-r--r--dev-util/ccache/ccache-3.7.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/dev-util/ccache/Manifest b/dev-util/ccache/Manifest
index 90c9e12b9d0a..e046671cf77c 100644
--- a/dev-util/ccache/Manifest
+++ b/dev-util/ccache/Manifest
@@ -3,3 +3,4 @@ DIST ccache-3.3.4.tar.xz 314468 BLAKE2B 6e465598df428979a2c821a698afef25c05d0904
DIST ccache-3.5.1a.tar.xz 335888 BLAKE2B 66c044b39dd42c91327e02528a4d6c917ac012c2d08190f7dbc2029ed6d1525aa3a6262fb7528f1721cec510306baa59b498a5afbcf955bb6aaf13594c00d178 SHA512 8a2e9eb06ba21fcf92084afd94fc221168693de545e0448f4da2098bef2bcbfdb017117c325b0bab4931b9e346dd8c1a9d1ebaed0cdc36496d9452985cdd1b43
DIST ccache-3.5.tar.xz 334668 BLAKE2B e3e2b63e8c4c8074514fb3a5794325fa05a4d52f48fc436ab0ad21b643ca4d1a1502c989cb47ed68972b105d4f1642e4fadc5ecef1235fe2bd3be5d218094a79 SHA512 92181fb794f06dc231baa4193c37e8f1d844c9281fd64bcb8f4b35c87b4a88dfc9bf36b810b37151ee85699778fcd3783818949a7010e619aeca7e3b33b7a2e3
DIST ccache-3.6.tar.xz 340608 BLAKE2B fa92180f53612f84b71c68da4acccefee129e5bfc9b269caa45a9c16219ed835ccf034d61ff938a54f3673fa23410d960475cc37cf5d27d7be641e7518a43f0a SHA512 13ce4c9084983ce77617cf005235987715cd6b630dac13a17cb9badce24aab71bff505e63da4206878e32d337cc674f05fbf78540711ec5b33a0b8384c47fa0d
+DIST ccache-3.7.tar.xz 348764 BLAKE2B a80ac0d5d94ff5d1aaee45a186037a9c8346c5e44d00afd29a4ba40b4fca877cd30b82357f344bed77f5caeb333bacfde8aff46d8fb866b484a3a1d3e5f513f5 SHA512 b8a5944072fcf8280b63ddbd6e2fcbc04d4ee99c0b2d3bfb9b47f61e760ce1dc5e191cf3f6437431b6d08af6cfb2162d6a2021ad49fd6746e531eb03cc26fd2e
diff --git a/dev-util/ccache/ccache-3.7.ebuild b/dev-util/ccache/ccache-3.7.ebuild
new file mode 100644
index 000000000000..b8912ddeeee1
--- /dev/null
+++ b/dev-util/ccache/ccache-3.7.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="fast compiler cache"
+HOMEPAGE="https://ccache.dev/"
+SRC_URI="https://github.com/ccache/ccache/releases/download/v${PV}/ccache-${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE=""
+
+DEPEND="app-arch/xz-utils
+ sys-libs/zlib"
+RDEPEND="${DEPEND}
+ dev-util/shadowman
+ sys-apps/gentoo-functions"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.4-size-on-disk.patch #456178
+ "${FILESDIR}"/${PN}-3.5-nvcc-test.patch
+ "${FILESDIR}"/${PN}-3.6-disable-sized-cleanup.patch #649440
+)
+
+src_prepare() {
+ default
+
+ # make sure we always use system zlib
+ rm -rf src/zlib || die
+ sed \
+ -e "/^EPREFIX=/s:'':'${EPREFIX}':" \
+ "${FILESDIR}"/ccache-config-3 > ccache-config || die
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_test() {
+ emake check V=1
+}
+
+src_install() {
+ DOCS=( doc/{AUTHORS,MANUAL,NEWS}.adoc CONTRIBUTING.md README.md )
+ default
+
+ dobin ccache-config
+ insinto /usr/share/shadowman/tools
+ newins - ccache <<<'/usr/lib/ccache/bin'
+
+ DOC_CONTENTS="
+To use ccache with **non-Portage** C compiling, add
+'${EPREFIX}/usr/lib/ccache/bin' to the beginning of your path, before
+'${EPREFIX}/usr/bin'. Portage will automatically take advantage of ccache with
+no additional steps. If this is your first install of ccache, type
+something like this to set a maximum cache size of 2GB:\\n
+# ccache -M 2G\\n
+If you are upgrading from an older version than 3.x you should clear all of your caches like so:\\n
+# CCACHE_DIR='${CCACHE_DIR:-${PORTAGE_TMPDIR}/ccache}' ccache -C\\n
+ccache now supports sys-devel/clang and dev-lang/icc, too!"
+
+ readme.gentoo_create_doc
+}
+
+pkg_prerm() {
+ if [[ -z ${REPLACED_BY_VERSION} && ${ROOT:-/} == / ]] ; then
+ eselect compiler-shadow remove ccache
+ fi
+}
+
+pkg_postinst() {
+ if [[ ${ROOT:-/} == / ]]; then
+ eselect compiler-shadow update ccache
+ fi
+
+ # nuke broken symlinks from previous versions that shouldn't exist
+ rm -rf "${EROOT}"/usr/lib/ccache.backup || die
+
+ readme.gentoo_print_elog
+}