summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-01-12 11:51:14 +0100
committerMichał Górny <mgorny@gentoo.org>2017-01-12 16:25:28 +0100
commite5f72dba87d521fdce3dba34558b13b4f3e91b0f (patch)
tree3a44bcfe2e047b33f2be0fe76d240f94c046e8b1 /dev-util
parentsys-devel/lld: Switch to CMAKE_BUILD_TYPE=RelWithDebInfo (diff)
downloadgentoo-e5f72dba87d521fdce3dba34558b13b4f3e91b0f.tar.gz
gentoo-e5f72dba87d521fdce3dba34558b13b4f3e91b0f.tar.bz2
gentoo-e5f72dba87d521fdce3dba34558b13b4f3e91b0f.zip
dev-util/lldb: Switch to CMAKE_BUILD_TYPE=RelWithDebInfo
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/lldb/lldb-9999.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-util/lldb/lldb-9999.ebuild b/dev-util/lldb/lldb-9999.ebuild
index 5558e00c211f..23dadf6b0621 100644
--- a/dev-util/lldb/lldb-9999.ebuild
+++ b/dev-util/lldb/lldb-9999.ebuild
@@ -5,6 +5,8 @@
EAPI=6
: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+# (needed due to CMAKE_BUILD_TYPE != Gentoo)
+CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
inherit cmake-utils git-r3 python-single-r1 toolchain-funcs
@@ -37,6 +39,9 @@ DEPEND="${RDEPEND}
REQUIRED_USE=${PYTHON_REQUIRED_USE}
+# least intrusive of all
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
src_unpack() {
if use test; then
# needed for patched gtest