summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-09-13 15:38:33 -0400
committerMatt Turner <mattst88@gentoo.org>2022-09-13 16:06:00 -0400
commitf41702b5494753fd5af0684cf740a4a4d7aaba70 (patch)
tree6840e4574a42fbb81d87a7d511a5dda36c6066b7 /dev-util
parentdev-cpp/gtkmm: Version bump to 4.8.0 (diff)
downloadgentoo-f41702b5494753fd5af0684cf740a4a4d7aaba70.tar.gz
gentoo-f41702b5494753fd5af0684cf740a4a4d7aaba70.tar.bz2
gentoo-f41702b5494753fd5af0684cf740a4a4d7aaba70.zip
dev-util/meld: Version bump to 3.22.0
Closes: https://bugs.gentoo.org/737138 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/meld/Manifest1
-rw-r--r--dev-util/meld/meld-3.22.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/meld/Manifest b/dev-util/meld/Manifest
index 3fdeaf8b3ec7..495b1a8d931f 100644
--- a/dev-util/meld/Manifest
+++ b/dev-util/meld/Manifest
@@ -1 +1,2 @@
DIST meld-3.20.4.tar.xz 617020 BLAKE2B 70bdd7c6ecfd4dd99d1bc0b503900da65563ba74469b97590da4971d0597d4023cf74a3fd6300701d73fe7ed1b646089a5b23527e4a519313816f53c31632dad SHA512 e7b5c07e68972e7e8e4d396140fa2ee627609728533269f1bc52e9339e89a58f0949a1e8ec7b7847eec3eff5a67ea0bd5e07ad8002d2c640d173f9b0c4aa724e
+DIST meld-3.22.0.tar.xz 674212 BLAKE2B 1d5af5fa9943c46fd150bd1e1c74003579a0017dea56178e92c4ba0dd1ba0bc3348a6f2625bfe5191fe4d8394b06462a30f2173ae623ffd32c637642f9c36183 SHA512 4cc1c9a76379401c1f116292bb4730301ec0f2413cdab7b463ed519ea7ee0ee86143a9c83a13f1ef09860aad192c04769d111bfb1eb10b5e1bc81fb44c530526
diff --git a/dev-util/meld/meld-3.22.0.ebuild b/dev-util/meld/meld-3.22.0.ebuild
new file mode 100644
index 000000000000..546bbe598e0a
--- /dev/null
+++ b/dev-util/meld/meld-3.22.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit gnome.org meson python-single-r1
+
+DESCRIPTION="A graphical diff and merge tool"
+HOMEPAGE="http://meldmerge.org/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=x11-libs/gtk+-3.20:3[introspection]
+ >=dev-libs/glib-2.48:2
+ >=x11-libs/gtksourceview-4.0.0:4[introspection]
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.30:3[cairo,${PYTHON_USEDEP}]
+ ')
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/pango-1.34[introspection]
+ x11-themes/hicolor-icon-theme
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-util/desktop-file-utils
+ dev-libs/appstream-glib
+ )
+"
+BDEPEND="
+ dev-util/intltool
+ dev-util/itstool
+ sys-devel/gettext
+ $(python_gen_cond_dep 'dev-python/distro[${PYTHON_USEDEP}]')
+"
+# dev-python/distro is soft-required in BDEPEND for python3.8 and onwards,
+# but it's mainly needed for debian and derivatives - seems the fallback
+# works fine, as we aren't a special_case, just an annoying warning.
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dprofile=''
+ -Dbyte-compile=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_optimize
+}