summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2019-10-21 00:20:08 +0200
committerDavid Seifert <soap@gentoo.org>2019-10-21 00:36:57 +0200
commitfdce6d04465e2e25a6915f286965521b702ded70 (patch)
tree950397bc5673cb240b25a9f2bfeb8cbbb428b5cc /dev-util
parentsys-kernel/git-sources: Linux patch 5.4-rc4 (diff)
downloadgentoo-fdce6d04465e2e25a6915f286965521b702ded70.tar.gz
gentoo-fdce6d04465e2e25a6915f286965521b702ded70.tar.bz2
gentoo-fdce6d04465e2e25a6915f286965521b702ded70.zip
dev-util/colm: various fixes
* EAPI 7 * license fix * do not install static library Closes: https://bugs.gentoo.org/698066 Closes: https://github.com/gentoo/gentoo/pull/13293 Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/colm/colm-0.13.0.6-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/colm/colm-0.13.0.6-r1.ebuild b/dev-util/colm/colm-0.13.0.6-r1.ebuild
new file mode 100644
index 000000000000..24c79169a62c
--- /dev/null
+++ b/dev-util/colm/colm-0.13.0.6-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="COmputer Language Manipulation"
+HOMEPAGE="https://www.colm.net/open-source/colm/"
+SRC_URI="https://www.colm.net/files/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="app-text/asciidoc"
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}