summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-10-04 00:45:40 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-10-04 00:45:55 +0200
commitff1a194d011725da2f0971381ad43141589096a2 (patch)
tree5637fb3dca63e2369243cbcaefd08a84cadc8c36 /dev-util
parentgames-action/supermariowar: fix warning. (diff)
downloadgentoo-ff1a194d011725da2f0971381ad43141589096a2.tar.gz
gentoo-ff1a194d011725da2f0971381ad43141589096a2.tar.bz2
gentoo-ff1a194d011725da2f0971381ad43141589096a2.zip
dev-util/webstorm: fix warning.
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/webstorm/webstorm-2017.2.4.172.4155.35.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-util/webstorm/webstorm-2017.2.4.172.4155.35.ebuild b/dev-util/webstorm/webstorm-2017.2.4.172.4155.35.ebuild
index e5e229b61de7..cd605cc309aa 100644
--- a/dev-util/webstorm/webstorm-2017.2.4.172.4155.35.ebuild
+++ b/dev-util/webstorm/webstorm-2017.2.4.172.4155.35.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-
EAPI=6
+
inherit eutils versionator
DESCRIPTION="JavaScript IDE for client- and server-side development with Node.js"
@@ -14,6 +14,7 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND=">=virtual/jdk-1.7"
+
S="${WORKDIR}/WebStorm-$(get_version_component_range 4-6)"
src_install() {
@@ -24,4 +25,4 @@ src_install() {
make_wrapper "${PN}" "/opt/${PN}/bin/${PN}.sh"
newicon "bin/${PN}.svg" "${PN}.svg"
make_desktop_entry "${PN}" "${PN}" "${PN}" "Development;IDE;"
-} \ No newline at end of file
+}