summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael G. Martins <rafaelmartins@gentoo.org>2015-08-23 14:15:48 -0300
committerRafael G. Martins <rafaelmartins@gentoo.org>2015-08-23 14:16:09 -0300
commit27d81d22599783af500d4b14cf72ec20aeee2640 (patch)
treeb8d0f573f900c229f5b8dcb92d7744e74139e98e /dev-vcs/blogc-git-receiver
parentgnome-extra/nautilus-tracker-tags: version bump (diff)
downloadgentoo-27d81d22599783af500d4b14cf72ec20aeee2640.tar.gz
gentoo-27d81d22599783af500d4b14cf72ec20aeee2640.tar.bz2
gentoo-27d81d22599783af500d4b14cf72ec20aeee2640.zip
dev-vcs/blogc-git-receiver: initial commit
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-vcs/blogc-git-receiver')
-rw-r--r--dev-vcs/blogc-git-receiver/Manifest1
-rw-r--r--dev-vcs/blogc-git-receiver/blogc-git-receiver-0.1_beta1.ebuild40
-rw-r--r--dev-vcs/blogc-git-receiver/blogc-git-receiver-9999.ebuild40
-rw-r--r--dev-vcs/blogc-git-receiver/metadata.xml18
4 files changed, 99 insertions, 0 deletions
diff --git a/dev-vcs/blogc-git-receiver/Manifest b/dev-vcs/blogc-git-receiver/Manifest
new file mode 100644
index 000000000000..456130301db0
--- /dev/null
+++ b/dev-vcs/blogc-git-receiver/Manifest
@@ -0,0 +1 @@
+DIST blogc-git-receiver-0.1-beta.1.tar.xz 68348 SHA256 499fc3eb9d2f0f9dcdf28d775b32ac66fc574ca3f82d2e580838d614ba09230e SHA512 ab272647dcace872e89bc79897167247ecce6fb4c826a0b6886c12e827ccb8bccb1256827de8129caaacdce7231a46c8b799a27d2b33f1f76c6b97d62cddf9e9 WHIRLPOOL 68711d41a08b17005f19e805ecf415d0b4034b3618acc13328a4cae281ba5bf3c291ebbe07fa314448e2d7b14dd73846e7a39d5d6199ae6312dc0b8c800b10da
diff --git a/dev-vcs/blogc-git-receiver/blogc-git-receiver-0.1_beta1.ebuild b/dev-vcs/blogc-git-receiver/blogc-git-receiver-0.1_beta1.ebuild
new file mode 100644
index 000000000000..7b071ab9713c
--- /dev/null
+++ b/dev-vcs/blogc-git-receiver/blogc-git-receiver-0.1_beta1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://github.com/blogc/blogc-git-receiver.git
+ https://github.com/blogc/blogc-git-receiver.git"
+ inherit git-r3 autotools
+fi
+
+DESCRIPTION="A simple login shell/git hook to deploy blogc websites"
+HOMEPAGE="https://github.com/blogc/blogc-git-receiver"
+
+MY_PV="${PV/_/-}"
+MY_PV="${MY_PV/beta/beta.}"
+
+MY_P="${PN}-${MY_PV}"
+
+SRC_URI="https://github.com/blogc/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-vcs/git"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ [[ ${PV} = *9999* ]] && eautoreconf
+ default
+}
diff --git a/dev-vcs/blogc-git-receiver/blogc-git-receiver-9999.ebuild b/dev-vcs/blogc-git-receiver/blogc-git-receiver-9999.ebuild
new file mode 100644
index 000000000000..7b071ab9713c
--- /dev/null
+++ b/dev-vcs/blogc-git-receiver/blogc-git-receiver-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://github.com/blogc/blogc-git-receiver.git
+ https://github.com/blogc/blogc-git-receiver.git"
+ inherit git-r3 autotools
+fi
+
+DESCRIPTION="A simple login shell/git hook to deploy blogc websites"
+HOMEPAGE="https://github.com/blogc/blogc-git-receiver"
+
+MY_PV="${PV/_/-}"
+MY_PV="${MY_PV/beta/beta.}"
+
+MY_P="${PN}-${MY_PV}"
+
+SRC_URI="https://github.com/blogc/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-vcs/git"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ [[ ${PV} = *9999* ]] && eautoreconf
+ default
+}
diff --git a/dev-vcs/blogc-git-receiver/metadata.xml b/dev-vcs/blogc-git-receiver/metadata.xml
new file mode 100644
index 000000000000..9ba75b936a96
--- /dev/null
+++ b/dev-vcs/blogc-git-receiver/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <longdescription lang="en">
+ A simple login shell/git hook to deploy blogc websites.
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <email>rafael@rafaelmartins.eng.br</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <remote-id type="github">blogc/blogc-git-receiver</remote-id>
+ </upstream>
+</pkgmetadata>