summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-05-06 19:15:19 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-05-06 19:15:51 +0100
commit2dcfed03e76a07abf9864f4ae3e619ad146c1f04 (patch)
treee8847494b3340cd494fd1b87af6041b23670d927 /dev-vcs/cvs-fast-export
parentdev-lang/erlang: bump up to 23.3.3 (diff)
downloadgentoo-2dcfed03e76a07abf9864f4ae3e619ad146c1f04.tar.gz
gentoo-2dcfed03e76a07abf9864f4ae3e619ad146c1f04.tar.bz2
gentoo-2dcfed03e76a07abf9864f4ae3e619ad146c1f04.zip
dev-vcs/cvs-fast-export: bump up to 1.57
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-vcs/cvs-fast-export')
-rw-r--r--dev-vcs/cvs-fast-export/Manifest1
-rw-r--r--dev-vcs/cvs-fast-export/cvs-fast-export-1.57.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-vcs/cvs-fast-export/Manifest b/dev-vcs/cvs-fast-export/Manifest
index e175b0b3e5cc..ab3886b3a297 100644
--- a/dev-vcs/cvs-fast-export/Manifest
+++ b/dev-vcs/cvs-fast-export/Manifest
@@ -1 +1,2 @@
DIST cvs-fast-export-1.56.tar.gz 492482 BLAKE2B 936f9f448dd6577122ace45380d8726f648fd31ffb9840bd931e343cc6c3f3526e4aa6f8735feb2a49d4d8df5fdb83ea54438e51951ea2be3b1ab221fdc11c33 SHA512 852a13fab095817a9650164c93f11aaeb4ced827489f20bde35baa492f6f125e82c3f35410899978706589105275536d98d973fbf482758ed054b3bbe9e3c581
+DIST cvs-fast-export-1.57.tar.gz 503473 BLAKE2B 06d5b03d550be9604a04b4f03cd19d06abbe84efb6fbb424a3ae8c58f2964dff31e1718baf61adf70fe17c2beb6753cdd0fba9e0e1a5ba5e9d8ae7b87721a336 SHA512 bb129d58a66ca8aa9feb6dcdf6d83553ed1099d6023041c4fb8fa9b923461b6eb9e59ec304b3443f754d7710a2655fd2c104cbaa5ac604ee471de727b92fc091
diff --git a/dev-vcs/cvs-fast-export/cvs-fast-export-1.57.ebuild b/dev-vcs/cvs-fast-export/cvs-fast-export-1.57.ebuild
new file mode 100644
index 000000000000..45dc138ac582
--- /dev/null
+++ b/dev-vcs/cvs-fast-export/cvs-fast-export-1.57.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="fast-export history from a CVS repository or RCS collection"
+HOMEPAGE="http://www.catb.org/~esr/cvs-fast-export/"
+SRC_URI="http://www.catb.org/~esr/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-text/asciidoc"
+
+RESTRICT=test # upstream does not ship some tests in tarball
+
+src_prepare() {
+ default
+
+ tc-export CC
+ export prefix="${EPREFIX}"/usr
+
+ # respect CC, CFLAGS and LDFLAGS
+ sed \
+ -e 's/cc /$(CC) $(LDFLAGS) /' \
+ -e 's/^CFLAGS += -O/#&/' \
+ -e 's/CFLAGS=/CFLAGS+=/' \
+ -i Makefile || die
+}
+
+src_compile() {
+ # '.adoc.html' rules can't be executed in parallel
+ # as they reuse the same 'docbook-xsl.css' file name.
+ emake -j1 html
+ # Allow full parallelism for the rest
+ emake
+}
+
+src_install() {
+ default
+ dodoc README.adoc
+}