summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-05-20 18:18:33 -0500
committerJohannes Huber <johu@gentoo.org>2018-05-27 23:59:33 +0200
commit7a18398debd78be2f7a19cf4420dac5ca182671d (patch)
tree159c09b4ec56fcbf4aa715357daeedb4ba11c8c9 /dev-vcs/cvsync/cvsync-9999.ebuild
parentdev-libs/polylib: git-2->git-r3, EAPI 0->6 (diff)
downloadgentoo-7a18398debd78be2f7a19cf4420dac5ca182671d.tar.gz
gentoo-7a18398debd78be2f7a19cf4420dac5ca182671d.tar.bz2
gentoo-7a18398debd78be2f7a19cf4420dac5ca182671d.zip
dev-vcs/cvsync: git-2->git-r3
Package-Manager: Portage-2.3.38, Repoman-2.3.9 Signed-off-by: Johannes Huber <johu@gentoo.org>
Diffstat (limited to 'dev-vcs/cvsync/cvsync-9999.ebuild')
-rw-r--r--dev-vcs/cvsync/cvsync-9999.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-vcs/cvsync/cvsync-9999.ebuild b/dev-vcs/cvsync/cvsync-9999.ebuild
index cda6f4f16922..f638af4de214 100644
--- a/dev-vcs/cvsync/cvsync-9999.ebuild
+++ b/dev-vcs/cvsync/cvsync-9999.ebuild
@@ -1,16 +1,17 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=6
inherit toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/cvsync/cvsync.git"
- inherit git-2
+ inherit git-r3
else
SRC_URI="mirror://gentoo/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ S="${WORKDIR}/${PN}"
fi
DESCRIPTION="portable CVS repository synchronization utility"
@@ -29,8 +30,6 @@ RDEPEND="sys-libs/zlib
)"
DEPEND="${RDEPEND}"
-S="${WORKDIR}/${PN}"
-
maint_pkg_create() {
cd "${S}"
local ver=$(date --date="$(git log -n1 --pretty=format:%ci HEAD)" -u "+%Y.%m.%d.%H%M%S")
@@ -42,7 +41,7 @@ maint_pkg_create() {
src_unpack() {
if [[ ${PV} == "9999" ]] ; then
- git-2_src_unpack
+ git-r3_src_unpack
maint_pkg_create
else
default