summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2018-10-07 06:11:48 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2018-10-07 06:12:31 -0400
commitfbc138b43d00d65824f32bfef7fe085acc791f92 (patch)
tree98ce137635272b2574212e1e8dc31a7c41a66137 /dev-vcs/fossil
parentdev-python/more-itertools: Mark ~hppa too. (diff)
downloadgentoo-fbc138b43d00d65824f32bfef7fe085acc791f92.tar.gz
gentoo-fbc138b43d00d65824f32bfef7fe085acc791f92.tar.bz2
gentoo-fbc138b43d00d65824f32bfef7fe085acc791f92.zip
dev-vcs/fossil: Bump to 2.7
Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Aaron Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-vcs/fossil')
-rw-r--r--dev-vcs/fossil/Manifest1
-rw-r--r--dev-vcs/fossil/fossil-2.7.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-vcs/fossil/Manifest b/dev-vcs/fossil/Manifest
index 93cd33572d3e..079655e7b6d0 100644
--- a/dev-vcs/fossil/Manifest
+++ b/dev-vcs/fossil/Manifest
@@ -1 +1,2 @@
DIST fossil-src-2.6.tar.gz 5083119 BLAKE2B 7d5cbeb072c72574b9f4fcbc87f9aeaa1db7964f961aa206a04bf64d73782bd6d51f2a19973fa4125969c864031cf78790a67acd32c5e8f209fe1211410a6af4 SHA512 a4f3b2ee696a7f156a295672c17e8ec63737a85cee5d47b1f66a9d45a6011006ed0a075082b5e06e5d75d59babef493d1815ec45f8ae99f42ed1a1c7a2447b1c
+DIST fossil-src-2.7.tar.gz 5276161 BLAKE2B 7a8a81515075be6d3fc68dac7a293a1ed6b46c0ed2ecf180269d7215e6cc16d796206b648588ab5b6e04176c553cc89556deb5e47683de1eb26ab7469a8c75c9 SHA512 c1f52209bf14cb1b0a134b03fd02926c123bfd38d9b0d45f39d3137f3df2be13371f38611dc66d1d7df71d95c79baf26e66ccb845c769a57b9568629cdd52672
diff --git a/dev-vcs/fossil/fossil-2.7.ebuild b/dev-vcs/fossil/fossil-2.7.ebuild
new file mode 100644
index 000000000000..f41e164254ff
--- /dev/null
+++ b/dev-vcs/fossil/fossil-2.7.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple, high-reliability, source control management, and more"
+HOMEPAGE="http://www.fossil-scm.org/"
+SRC_URI="http://www.fossil-scm.org/index.html/uv/fossil-src-${PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="debug fusefs json -legacy-mv-rm -miniz system-sqlite +ssl static
+ tcl tcl-stubs tcl-private-stubs th1-docs th1-hooks"
+
+REQUIRED_USE="ssl? ( !miniz )"
+
+DEPEND="
+ sys-libs/zlib
+ || ( sys-libs/readline:0 dev-libs/libedit )
+ system-sqlite? ( >=dev-db/sqlite-3.25.0:3 )
+ ssl? ( dev-libs/openssl:0 )
+ tcl? ( dev-lang/tcl:0= )
+"
+RDEPEND="${DEPEND}"
+
+# Tests can't be run from the build directory
+RESTRICT="test"
+
+src_configure() {
+ # this is not an autotools situation so don't make it seem like one
+ # --with-tcl: works
+ # --without-tcl: dies
+ local myconf="--with-openssl=$(usex ssl auto none)"
+ use debug && myconf+=' --fossil-debug'
+ use json && myconf+=' --json'
+ use system-sqlite && myconf+=' --disable-internal-sqlite'
+ use static && myconf+=' --static'
+ use tcl && myconf+=' --with-tcl=1'
+ use fusefs || myconf+=' --disable-fusefs'
+
+ local u useflags
+ useflags=( legacy-mv-rm miniz tcl-stubs tcl-private-stubs
+ th1-docs th1-hooks )
+ for u in ${useflags[@]} ; do
+ use ${u} && myconf+=" --with-${u}"
+ done
+
+ tc-export CC
+ ./configure ${myconf} || die
+}
+
+src_install() {
+ dobin fossil
+}