summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-03-11 15:57:16 +0100
committerUlrich Müller <ulm@gentoo.org>2020-03-11 15:57:16 +0100
commit4230d68e33438d5e88e5e49811d65ef0658a9fac (patch)
tree02019693247c9cd6c78ac9b4cd36d0e66fac5edb /dev-vcs/ghp-import/ghp-import-0.4.1-r1.ebuild
parentapp-doc/doxygen: restrict to <sys-devel/clang-10 (diff)
downloadgentoo-4230d68e33438d5e88e5e49811d65ef0658a9fac.tar.gz
gentoo-4230d68e33438d5e88e5e49811d65ef0658a9fac.tar.bz2
gentoo-4230d68e33438d5e88e5e49811d65ef0658a9fac.zip
dev-python/ghp-import: Move package to dev-vcs/ghp-import.
Add also a move entry for app-doc because of the earlier package move in commit b43a50d73da and its revert in commit 69b1702a753. Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'dev-vcs/ghp-import/ghp-import-0.4.1-r1.ebuild')
-rw-r--r--dev-vcs/ghp-import/ghp-import-0.4.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-vcs/ghp-import/ghp-import-0.4.1-r1.ebuild b/dev-vcs/ghp-import/ghp-import-0.4.1-r1.ebuild
new file mode 100644
index 000000000000..c6fb4d58de59
--- /dev/null
+++ b/dev-vcs/ghp-import/ghp-import-0.4.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Copy your docs directly to the gh-pages branch"
+HOMEPAGE="https://github.com/davisp/ghp-import"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="tumbolia"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_prepare_all() {
+ ebegin 'patching setup.py'
+ sed \
+ -e '4ifrom codecs import open\n' \
+ -e '/LONG_DESC/s/))/), encoding = "utf-8")/' \
+ -i setup.py
+ STATUS=${?}
+ eend ${STATUS}
+ [[ ${STATUS} -gt 0 ]] && die
+
+ distutils-r1_python_prepare_all
+}