summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-06-05 10:51:24 +0200
committerJohannes Huber <johu@gentoo.org>2017-06-05 10:51:45 +0200
commit6fcd22e6f3d83e9d4c75284cb348047783b180c5 (patch)
treec02d22435778e4657e45de51322d65d49f6dd366 /dev-vcs/git-flow/git-flow-1.11.0.ebuild
parentdev-ruby/yajl-ruby: add ruby24 (diff)
downloadgentoo-6fcd22e6f3d83e9d4c75284cb348047783b180c5.tar.gz
gentoo-6fcd22e6f3d83e9d4c75284cb348047783b180c5.tar.bz2
gentoo-6fcd22e6f3d83e9d4c75284cb348047783b180c5.zip
dev-vcs/git-flow: Version bump 1.11.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-vcs/git-flow/git-flow-1.11.0.ebuild')
-rw-r--r--dev-vcs/git-flow/git-flow-1.11.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-vcs/git-flow/git-flow-1.11.0.ebuild b/dev-vcs/git-flow/git-flow-1.11.0.ebuild
new file mode 100644
index 000000000000..a90de66ee5e3
--- /dev/null
+++ b/dev-vcs/git-flow/git-flow-1.11.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-/}-avh"
+COMP_PN="${PN}-completion"
+COMP_PV="0.6.0"
+COMP_P="${COMP_PN}-${COMP_PV}"
+inherit bash-completion-r1
+
+DESCRIPTION="Git extensions to provide high-level repository operations"
+HOMEPAGE="https://github.com/petervanderdoes/gitflow-avh"
+SRC_URI="https://github.com/petervanderdoes/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+https://github.com/petervanderdoes/${COMP_PN}/archive/${COMP_PV}.tar.gz -> ${COMP_P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-vcs/git
+"
+
+DOCS=( AUTHORS CHANGELOG.md README.md )
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_compile() {
+ true
+}
+
+src_install() {
+ emake prefix="${D}/usr" install
+ einstalldocs
+ newbashcomp "${WORKDIR}/${COMP_P}/${COMP_PN}.bash" ${PN}
+}