summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-05-05 19:15:43 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-05-05 19:15:43 -0400
commita7fd11fb3319f9d2cff549dd9f66f03d9b5fa4cc (patch)
tree471b74728c8ae220ae42b1596b4c111239986af4 /dev-vcs/git-imerge/git-imerge-1.0.0.ebuild
parentdev-vcs/git-imerge: remove unused version 0.7.0. (diff)
downloadgentoo-a7fd11fb3319f9d2cff549dd9f66f03d9b5fa4cc.tar.gz
gentoo-a7fd11fb3319f9d2cff549dd9f66f03d9b5fa4cc.tar.bz2
gentoo-a7fd11fb3319f9d2cff549dd9f66f03d9b5fa4cc.zip
dev-vcs/git-imerge: new version 1.0.0.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-vcs/git-imerge/git-imerge-1.0.0.ebuild')
-rw-r--r--dev-vcs/git-imerge/git-imerge-1.0.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-vcs/git-imerge/git-imerge-1.0.0.ebuild b/dev-vcs/git-imerge/git-imerge-1.0.0.ebuild
new file mode 100644
index 000000000000..cd805b4ba985
--- /dev/null
+++ b/dev-vcs/git-imerge/git-imerge-1.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit bash-completion-r1 python-r1
+
+DESCRIPTION="Incremental merge for git"
+HOMEPAGE="https://github.com/mhagger/git-imerge"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-vcs/git"
+DEPEND="dev-python/docutils"
+
+src_compile() {
+ for doc in *.rst; do
+ rst2html.py "${doc}" > "${T}/${doc/.rst/.html}" \
+ || die "failed to convert ${doc} to ${T}/${doc/.rst/.html}"
+ done
+
+ rst2s5.py \
+ --theme=small-white \
+ --current-slide \
+ doc/presentations/GitMerge-2013/talk.rst \
+ "${T}/talk.html" \
+ || die 'failed to convert talk.rst to ${T}/talk.html'
+}
+
+src_install() {
+ python_foreach_impl python_doscript "${PN}"
+ newbashcomp "${FILESDIR}/git-imerge.bashcomplete" git-imerge
+ dodoc *.rst "${T}"/*.html
+
+ # Don't forget the CSS for the presentation.
+ dodoc -r "${T}/ui"
+}