summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2022-04-21 16:26:31 +0800
committerYixun Lan <dlan@gentoo.org>2022-04-26 16:41:47 +0800
commit89997ca88b0c8241e8fa5f24bfc6a7d82b6290fe (patch)
treebd80e25f66561bddb81a747ea4e964ce31aaed74 /dev-vcs/git-publish/git-publish-1.8.0.ebuild
parentapp-backup/snapper: drop 0.10.0 (diff)
downloadgentoo-89997ca88b0c8241e8fa5f24bfc6a7d82b6290fe.tar.gz
gentoo-89997ca88b0c8241e8fa5f24bfc6a7d82b6290fe.tar.bz2
gentoo-89997ca88b0c8241e8fa5f24bfc6a7d82b6290fe.zip
dev-vcs/git-publish: add 1.8.0
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-vcs/git-publish/git-publish-1.8.0.ebuild')
-rw-r--r--dev-vcs/git-publish/git-publish-1.8.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-vcs/git-publish/git-publish-1.8.0.ebuild b/dev-vcs/git-publish/git-publish-1.8.0.ebuild
new file mode 100644
index 000000000000..e88b6924fa56
--- /dev/null
+++ b/dev-vcs/git-publish/git-publish-1.8.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit python-single-r1
+
+DESCRIPTION="Tool for preparing and storing patch revisions as git tag"
+HOMEPAGE="https://github.com/stefanha/git-publish"
+SRC_URI="https://github.com/stefanha/git-publish/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+man"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-vcs/git
+"
+BDEPEND="${PYTHON_DEPS}
+ man? ( dev-lang/perl )
+"
+
+src_prepare() {
+ default
+ python_fix_shebang git-publish
+}
+
+src_compile() {
+ if use man; then
+ pod2man --center "git-publish Documentation" --release "${PV}" \
+ git-publish.pod git-publish.1 || die
+ fi
+}
+
+src_install() {
+ dobin git-publish
+ use man && doman git-publish.1
+ insinto /usr/share/${PN}/hooks
+ doins hooks/pre-publish-send-email.example
+}