summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2021-03-18 09:17:07 +0800
committerYixun Lan <dlan@gentoo.org>2021-03-19 11:41:31 +0800
commit3c39b091100eb0c3a56ef34b69a46fed0a16465e (patch)
tree07d8e9f65eeed9ee3beee5cedd875747f9335850 /dev-vcs/git-pw/git-pw-2.0.0.ebuild
parentdev-vcs/git-publish: add version 1.7.0 (diff)
downloadgentoo-3c39b091100eb0c3a56ef34b69a46fed0a16465e.tar.gz
gentoo-3c39b091100eb0c3a56ef34b69a46fed0a16465e.tar.bz2
gentoo-3c39b091100eb0c3a56ef34b69a46fed0a16465e.zip
dev-vcs/git-pw: add version 2.0.0
A handy tool to work with patchwork Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-vcs/git-pw/git-pw-2.0.0.ebuild')
-rw-r--r--dev-vcs/git-pw/git-pw-2.0.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-vcs/git-pw/git-pw-2.0.0.ebuild b/dev-vcs/git-pw/git-pw-2.0.0.ebuild
new file mode 100644
index 000000000000..8efc99b1623b
--- /dev/null
+++ b/dev-vcs/git-pw/git-pw-2.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+if [[ "${PV}" == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/getpatchwork/git-pw.git"
+else
+ SRC_URI="https://github.com/getpatchwork/git-pw/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A tool for integrating Git with Patchwork"
+HOMEPAGE="https://github.com/getpatchwork/git-pw"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/arrow-0.10[${PYTHON_USEDEP}]
+ <dev-python/click-8.0[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ <dev-python/requests-3.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/mock-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/pytest-6.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.5[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/${P}-version.patch" )
+
+distutils_enable_tests pytest