summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2023-01-04 08:53:34 +0800
committerYixun Lan <dlan@gentoo.org>2023-01-04 09:05:06 +0800
commitd3ee3cdc812b0d85339b7ec58f7918ebdae75153 (patch)
tree8a7bfb083eaf64fad2d6382c398228159f15f40c /dev-vcs/git-pw
parentdev-vcs/git-pw: add 2.4.0 (diff)
downloadgentoo-d3ee3cdc812b0d85339b7ec58f7918ebdae75153.tar.gz
gentoo-d3ee3cdc812b0d85339b7ec58f7918ebdae75153.tar.bz2
gentoo-d3ee3cdc812b0d85339b7ec58f7918ebdae75153.zip
dev-vcs/git-pw: drop 2.3.0
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-vcs/git-pw')
-rw-r--r--dev-vcs/git-pw/Manifest1
-rw-r--r--dev-vcs/git-pw/git-pw-2.3.0.ebuild45
2 files changed, 0 insertions, 46 deletions
diff --git a/dev-vcs/git-pw/Manifest b/dev-vcs/git-pw/Manifest
index 90cb1110dc99..2db8f699d829 100644
--- a/dev-vcs/git-pw/Manifest
+++ b/dev-vcs/git-pw/Manifest
@@ -1,2 +1 @@
-DIST git-pw-2.3.0.tar.gz 34301 BLAKE2B b1bba3696c1d658ee76900d0787121dd5f89143774c7f7e79971f89b391d66c454a3f3f4103c35bc6a0bd77113e990f915b8313b855f7946518c033222e26419 SHA512 b83d7ad5c8e4f7f28e6df09ea286cef41940b76d8ac0eedf1993a7beeefd8a62298f4a4f9e6c0988c68811091f1740548e85ba1b689464447fa7fe74d31eb7b6
DIST git-pw-2.4.0.tar.gz 34874 BLAKE2B cc44b3e8660e8ede70a32b2e7d79dc000c050a7359b9d092df535bb0d79f79dc6c95f2b8563e7f750cc74618530db376a1dee08802bc1f2f4b7239b1f4fe57c3 SHA512 5a2b22d33903c779d319a40afbce8f7137272d5fcd4ebd62901b59468333523aea3c276b56cc7227d4aa2b53c30664ac07858bab2f80ef99a55a28af0feecefb
diff --git a/dev-vcs/git-pw/git-pw-2.3.0.ebuild b/dev-vcs/git-pw/git-pw-2.3.0.ebuild
deleted file mode 100644
index 8658b3068beb..000000000000
--- a/dev-vcs/git-pw/git-pw-2.3.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-if [[ "${PV}" == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/getpatchwork/git-pw.git"
-else
- SRC_URI="https://github.com/getpatchwork/git-pw/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="A tool for integrating Git with Patchwork"
-HOMEPAGE="https://github.com/getpatchwork/git-pw"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- >=dev-python/arrow-0.10[${PYTHON_USEDEP}]
- >=dev-python/click-6.0[${PYTHON_USEDEP}]
- dev-python/pbr[${PYTHON_USEDEP}]
- <dev-python/requests-3.0[${PYTHON_USEDEP}]
- >=dev-python/tabulate-0.8[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/pbr[${PYTHON_USEDEP}]
- test? (
- >=dev-python/mock-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-cov-2.5[${PYTHON_USEDEP}]
- )
-"
-
-src_compile() {
- export PBR_VERSION=${PV}
- distutils-r1_src_compile
-}
-distutils_enable_tests pytest