summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-05-24 10:48:43 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-05-24 10:49:00 +0200
commit7ef9302c5539aa6ea229ed1aacca2f07cfeeecdb (patch)
treedd0dd70546756e0822cadfdea2d2102ee41e5b53 /dev-vcs/git/git-9999-r2.ebuild
parentdev-vcs/git: Removed old. (diff)
downloadgentoo-7ef9302c5539aa6ea229ed1aacca2f07cfeeecdb.tar.gz
gentoo-7ef9302c5539aa6ea229ed1aacca2f07cfeeecdb.tar.bz2
gentoo-7ef9302c5539aa6ea229ed1aacca2f07cfeeecdb.zip
dev-vcs/git: Replace "libsecret" by "gnome-keyring" USE flag (bug #619484)
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-vcs/git/git-9999-r2.ebuild')
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index f725b2c09472..269086404b39 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -42,13 +42,13 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs +gpg highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
+ gnome-keyring? ( app-crypt/libsecret )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
- libsecret? ( app-crypt/libsecret )
sys-libs/zlib
pcre? ( dev-libs/libpcre )
perl? ( dev-lang/perl:=[-build(-)] )
@@ -358,7 +358,7 @@ src_compile() {
cd "${S}"
fi
- if use libsecret ; then
+ if use gnome-keyring ; then
cd "${S}"/contrib/credential/libsecret
git_emake || die "emake git-credential-libsecret failed"
fi
@@ -453,7 +453,7 @@ src_install() {
doexe contrib/contacts/git-contacts
dodoc contrib/contacts/git-contacts.txt
- if use libsecret ; then
+ if use gnome-keyring ; then
cd "${S}"/contrib/credential/libsecret
dobin git-credential-libsecret
fi