summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2017-08-05 17:04:59 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2017-08-05 17:12:20 -0700
commit541e9759ca8143d7e446de7cc353417dd45f5a71 (patch)
tree5f9cb0f05ab6a077fd86b74e39dbe3b533f9baeb /dev-vcs/git/git-9999.ebuild
parentdev-vcs/git: sync 9999 builds to latest release. (diff)
downloadgentoo-541e9759ca8143d7e446de7cc353417dd45f5a71.tar.gz
gentoo-541e9759ca8143d7e446de7cc353417dd45f5a71.tar.bz2
gentoo-541e9759ca8143d7e446de7cc353417dd45f5a71.zip
dev-vcs/git: switch to PCRE2-JIT per upstream.
Upstream Git is switching to PCRE2 w/ JIT by default, because of the performance boost. An optional non-JIT PCRE is available in PCRE1 code path, for arches where dev-libs/libpcre2[jit] is not available (alpha, ia64, hppa as of this commit). Closes: https://bugs.gentoo.org/show_bug.cgi?id=627088 Bug: https://bugs.gentoo.org/show_bug.cgi?id=627088 Package-Manager: portage-2.3.6
Diffstat (limited to 'dev-vcs/git/git-9999.ebuild')
-rw-r--r--dev-vcs/git/git-9999.ebuild21
1 files changed, 16 insertions, 5 deletions
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 1c670f22bcd9..4a0448a0496c 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -43,7 +43,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +pcre-jit +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -51,7 +51,10 @@ CDEPEND="
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
sys-libs/zlib
- pcre? ( dev-libs/libpcre )
+ pcre? (
+ pcre-jit? ( dev-libs/libpcre2[jit(+)] )
+ !pcre-jit? ( dev-libs/libpcre[-jit(-)] )
+ )
perl? ( dev-lang/perl:=[-build(-)] )
tk? ( dev-lang/tk:0= )
curl? (
@@ -108,6 +111,7 @@ REQUIRED_USE="
mediawiki-experimental? ( mediawiki )
subversion? ( perl )
webdav? ( curl )
+ pcre-jit? ( pcre )
python? ( ${PYTHON_REQUIRED_USE} )
"
@@ -173,9 +177,16 @@ exportmakeopts() {
|| myopts+=" NO_GETTEXT=YesPlease"
use tk \
|| myopts+=" NO_TCLTK=YesPlease"
- use pcre \
- && myopts+=" USE_LIBPCRE=yes" \
- && extlibs+=" -lpcre"
+ if use pcre; then
+ if use pcre-jit; then
+ myopts+=" USE_LIBPCRE2=YesPlease"
+ extlibs+=" -lpcre2-8"
+ else
+ myopts+=" USE_LIBPCRE1=YesPlease"
+ myopts+=" NO_LIBPCRE1_JIT=YesPlease"
+ extlibs+=" -lpcre"
+ fi
+ fi
use perl \
&& myopts+=" INSTALLDIRS=vendor" \
|| myopts+=" NO_PERL=YesPlease"