summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2018-05-20 22:08:08 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2018-05-20 22:08:21 -0700
commitd2f244bff1b9d0a3dc32f8e4f1b175f664b92592 (patch)
treeb55e1fa80c5c53c9ada5f1a8aa9a6e2f70bf9a62 /dev-vcs/git/git-9999.ebuild
parentdev-ruby/rake: cleanup (diff)
downloadgentoo-d2f244bff1b9d0a3dc32f8e4f1b175f664b92592.tar.gz
gentoo-d2f244bff1b9d0a3dc32f8e4f1b175f664b92592.tar.bz2
gentoo-d2f244bff1b9d0a3dc32f8e4f1b175f664b92592.zip
dev-vcs/git: improve perl packlist cleanup
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> Package-Manager: Portage-2.3.33, Repoman-2.3.9
Diffstat (limited to 'dev-vcs/git/git-9999.ebuild')
-rw-r--r--dev-vcs/git/git-9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 592c262cdb86..1fb66925cbfb 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -544,10 +544,10 @@ src_install() {
newdoc "${S}"/gitweb/README README.gitweb
for d in "${ED%/}"/usr/lib{,64}/perl5/ ; do
- test -d "$d" && find "${d}" \
+ if test -d "$d" ; then find "$d" \
-name .packlist \
- -delete \
- || die
+ -delete || die
+ fi
done
else
rm -rf "${ED%/}"/usr/share/gitweb