summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2017-08-05 17:10:57 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2017-08-05 17:12:17 -0700
commit486a1bae24f6cfbaf73b2c1930e6b67b5576414c (patch)
treea90501056513598fbdd6f0b62a79ca233d0b31c9 /dev-vcs/git
parentpackage.use.mask: block dev-vcs/git[pcre-jit] on non-JIT arches. (diff)
downloadgentoo-486a1bae24f6cfbaf73b2c1930e6b67b5576414c.tar.gz
gentoo-486a1bae24f6cfbaf73b2c1930e6b67b5576414c.tar.bz2
gentoo-486a1bae24f6cfbaf73b2c1930e6b67b5576414c.zip
dev-vcs/git: sync 9999 builds to latest release.
Diffstat (limited to 'dev-vcs/git')
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild6
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild6
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild6
-rw-r--r--dev-vcs/git/git-9999.ebuild6
4 files changed, 20 insertions, 4 deletions
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index 73c3a63eff54..e61e4dbc350b 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -37,7 +37,8 @@ if [[ ${PV} != *9999 ]]; then
doc? (
${SRC_URI_KORG}/${PN}-htmldocs-${DOC_VER}.tar.${SRC_URI_SUFFIX}
)"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ [[ "${PV}" = *_rc* ]] || \
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
LICENSE="GPL-2"
@@ -367,6 +368,9 @@ src_compile() {
git_emake
use doc && git_emake doc
+ cd "${S}"/contrib/diff-highlight || die
+ git_emake
+
if use mediawiki ; then
cd "${S}"/contrib/mw-to-git
git_emake
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index 269086404b39..7c6c767ea6e3 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -37,7 +37,8 @@ if [[ ${PV} != *9999 ]]; then
doc? (
${SRC_URI_KORG}/${PN}-htmldocs-${DOC_VER}.tar.${SRC_URI_SUFFIX}
)"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ [[ "${PV}" = *_rc* ]] || \
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
LICENSE="GPL-2"
@@ -367,6 +368,9 @@ src_compile() {
git_emake
use doc && git_emake doc
+ cd "${S}"/contrib/diff-highlight || die
+ git_emake
+
if use mediawiki ; then
cd "${S}"/contrib/mw-to-git
git_emake
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index 1d5145652541..f2270d9140f6 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -37,7 +37,8 @@ if [[ ${PV} != *9999 ]]; then
doc? (
${SRC_URI_KORG}/${PN}-htmldocs-${DOC_VER}.tar.${SRC_URI_SUFFIX}
)"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ [[ "${PV}" = *_rc* ]] || \
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
LICENSE="GPL-2"
@@ -367,6 +368,9 @@ src_compile() {
git_emake
use doc && git_emake doc
+ cd "${S}"/contrib/diff-highlight || die
+ git_emake
+
if use mediawiki ; then
cd "${S}"/contrib/mw-to-git
git_emake
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 1d2603cd7495..1c670f22bcd9 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -37,7 +37,8 @@ if [[ ${PV} != *9999 ]]; then
doc? (
${SRC_URI_KORG}/${PN}-htmldocs-${DOC_VER}.tar.${SRC_URI_SUFFIX}
)"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ [[ "${PV}" = *_rc* ]] || \
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
LICENSE="GPL-2"
@@ -367,6 +368,9 @@ src_compile() {
git_emake
use doc && git_emake doc
+ cd "${S}"/contrib/diff-highlight || die
+ git_emake
+
if use mediawiki ; then
cd "${S}"/contrib/mw-to-git
git_emake