summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2020-11-24 17:21:16 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2020-11-24 21:29:02 -0500
commit4102a43725302996cb63f8c7240fc161068afb81 (patch)
tree716405e9e7ed7e6b83903ee0e85d10a0ebbf028d /dev-vcs/gitstats/gitstats-0_pre20201124.ebuild
parentnet-fs/davfs2: bump to 1.6.0 (diff)
downloadgentoo-4102a43725302996cb63f8c7240fc161068afb81.tar.gz
gentoo-4102a43725302996cb63f8c7240fc161068afb81.tar.bz2
gentoo-4102a43725302996cb63f8c7240fc161068afb81.zip
dev-vcs/gitstats: bump to snapshot 0_pre20201124
Bug: https://bugs.gentoo.org/735338 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'dev-vcs/gitstats/gitstats-0_pre20201124.ebuild')
-rw-r--r--dev-vcs/gitstats/gitstats-0_pre20201124.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-vcs/gitstats/gitstats-0_pre20201124.ebuild b/dev-vcs/gitstats/gitstats-0_pre20201124.ebuild
new file mode 100644
index 000000000000..0fa1ffbc9f80
--- /dev/null
+++ b/dev-vcs/gitstats/gitstats-0_pre20201124.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-r1
+
+DESCRIPTION="Statistics generator for git"
+HOMEPAGE="http://gitstats.sourceforge.net/"
+SRC_URI="https://github.com/gktrk/gitstats/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 ) MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ sci-visualization/gnuplot[gd]
+ dev-vcs/git"
+DEPEND="
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ dev-lang/perl:*
+"
+
+DOCS=( doc/{AUTHOR,README,TODO.txt} )
+
+src_prepare() {
+ sed \
+ -e "s:basedirs = \[binarypath, secondarypath, '/usr/share/gitstats'\]:basedirs = \['${EPREFIX}/usr/share/gitstats'\]:g" \
+ -i gitstats || die "failed to fix static files path"
+ default
+}
+
+src_compile() {
+ emake VERSION="${PV}" man
+}
+
+src_install() {
+ emake PREFIX="${ED}"/usr VERSION="${PV}" install
+ doman doc/${PN}.1
+ einstalldocs
+ python_replicate_script "${ED}"/usr/bin/${PN}
+}