summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2015-08-27 20:20:12 -0600
committerChristoph Junghans <ottxor@gentoo.org>2015-08-27 20:23:23 -0600
commit946f0ad99537140416114728e4d8b25304cc65e9 (patch)
tree7489e23ad331eaf6caa5fb56e88b98faa1faaedb /dev-vcs/hg-fast-export
parentapp-editors/gummi: Bump EAPI, move upstream repository to git (diff)
downloadgentoo-946f0ad99537140416114728e4d8b25304cc65e9.tar.gz
gentoo-946f0ad99537140416114728e4d8b25304cc65e9.tar.bz2
gentoo-946f0ad99537140416114728e4d8b25304cc65e9.zip
dev-vcs/hg-fast-export: version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-vcs/hg-fast-export')
-rw-r--r--dev-vcs/hg-fast-export/Manifest1
-rw-r--r--dev-vcs/hg-fast-export/hg-fast-export-20150816.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-vcs/hg-fast-export/Manifest b/dev-vcs/hg-fast-export/Manifest
index 515f9b636973..19cb245685cb 100644
--- a/dev-vcs/hg-fast-export/Manifest
+++ b/dev-vcs/hg-fast-export/Manifest
@@ -1,2 +1,3 @@
DIST hg-fast-export-20140328.tar.gz 14436 SHA256 a580dcd0ab2205de8e59cd3c46a23661799e433293b5a8d52179632eead0a690 SHA512 9eb7613634a176a5f273f5f86d0cdc544b360e98743866e47cf36859e1a84e95bb88b646e7c36d8671b7c7e61a0601684c38372c95aa173d324b897d6db7a39c WHIRLPOOL 1dd863a7685713fe244d71af1d7ffcbcb45a0904fad0cd31be64b524c7e5d37bd51ad13c11205eb587e606b57148f86041f334423d808335bf3137c46be9ce31
DIST hg-fast-export-20140706.tar.gz 14671 SHA256 cab19797e7903fc7c6aeee00317d27608d1724837554c2dea47ac531b348cd73 SHA512 1c7421f6944af822dd0a6b8ac23c31f198b15da77a16773c5fd80371c3e059e1f45c1e67e5d88cfcf130e648252a76d923badf7fa2e0e3bd1a32e561c1c8f150 WHIRLPOOL 43d96daf9a77b18c7e7e2fe5375107a00e2b92f4ee1ed303534dfff42077b0a27c52ab65b89f308e3f5bda23f58a4f073537c60c69e94fed7f191e22bb04a49c
+DIST hg-fast-export-20150816.tar.gz 15245 SHA256 d1c31db38318ce8af1abcdc75a02ee9f738ff652f602309ce4ded884ad8d1406 SHA512 d6276c4f2eaaf580d2218f8561e9e60191dfcecdfbc612e0d216475fd16d1257c65ea95415cdd9a57a1c7f18773d616fad610a7931747e6579d6529e40a84a8a WHIRLPOOL fb6106fec5e33e26843d1967ce6f9eacb570906b5e77b62732820f85cc54eadcbd218a3e53c7fef00d9621865b0c976537e02c9f4c13a25fca53c57cf975d026
diff --git a/dev-vcs/hg-fast-export/hg-fast-export-20150816.ebuild b/dev-vcs/hg-fast-export/hg-fast-export-20150816.ebuild
new file mode 100644
index 000000000000..1d91066e0057
--- /dev/null
+++ b/dev-vcs/hg-fast-export/hg-fast-export-20150816.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1 vcs-snapshot
+
+COMMIT="3c27c693e13482059966003dd6545941b942a97a"
+DESCRIPTION="mercurial to git converter using git-fast-import"
+HOMEPAGE="https://github.com/frej/fast-export"
+SRC_URI="${HOMEPAGE}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-vcs/git
+ dev-vcs/mercurial
+ ${PYTHON_DEPS}"
+
+src_prepare() {
+ sed -e '/^PYTHON/s/python/&2.7/' \
+ -e '/^PYTHON/s/PYTHON:/E&/g' \
+ -e "/^ROOT/s:=.*:='${EPREFIX}/usr/bin':" \
+ -i "${PN}".sh || die
+ rm Makefile || die #don't compile old svn2git code
+}
+
+src_install() {
+ newbin "${PN}".sh "${PN}"
+ dodoc README
+ python_foreach_impl python_doexe "${PN}".py
+ python_foreach_impl python_domodule hg2git.py
+}