summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2016-02-20 11:43:15 +0100
committerDirkjan Ochtman <djc@gentoo.org>2016-02-20 11:43:15 +0100
commitdfc4c62ec52e5742875fa83be28016a4a3ef9c5f (patch)
tree11ddbb47fe7b270600547c9a391981359cd0c19b /dev-vcs/hg-git/hg-git-0.8.5.ebuild
parentmail-filter/rspamd: remove old versions (diff)
downloadgentoo-dfc4c62ec52e5742875fa83be28016a4a3ef9c5f.tar.gz
gentoo-dfc4c62ec52e5742875fa83be28016a4a3ef9c5f.tar.bz2
gentoo-dfc4c62ec52e5742875fa83be28016a4a3ef9c5f.zip
dev-vcs/hg-git: version bump to 0.8.5
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-vcs/hg-git/hg-git-0.8.5.ebuild')
-rw-r--r--dev-vcs/hg-git/hg-git-0.8.5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-vcs/hg-git/hg-git-0.8.5.ebuild b/dev-vcs/hg-git/hg-git-0.8.5.ebuild
new file mode 100644
index 000000000000..55574ccc9689
--- /dev/null
+++ b/dev-vcs/hg-git/hg-git-0.8.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="push to and pull from a Git repository using Mercurial"
+HOMEPAGE="http://hg-git.github.io https://pypi.python.org/pypi/hg-git"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ >=dev-vcs/mercurial-1.9.3[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.9.7[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"