summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-02-16 20:38:11 -0600
committerWilliam Hubbs <williamh@gentoo.org>2020-02-16 20:38:59 -0600
commita3ec2fcb6a45ab21173bbe4147b20da57cfc61c4 (patch)
tree3f0b7c21aa810f4408a897714bf6eb87a8438204 /dev-vcs/hub
parentsys-apps/baselayout: remove README from /etc/sysctl.d for OpenRC collision (diff)
downloadgentoo-a3ec2fcb6a45ab21173bbe4147b20da57cfc61c4.tar.gz
gentoo-a3ec2fcb6a45ab21173bbe4147b20da57cfc61c4.tar.bz2
gentoo-a3ec2fcb6a45ab21173bbe4147b20da57cfc61c4.zip
dev-vcs/hub: 2.14.1 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-vcs/hub')
-rw-r--r--dev-vcs/hub/Manifest1
-rw-r--r--dev-vcs/hub/hub-2.14.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-vcs/hub/Manifest b/dev-vcs/hub/Manifest
index d16a2148b986..d1ad35bca076 100644
--- a/dev-vcs/hub/Manifest
+++ b/dev-vcs/hub/Manifest
@@ -1 +1,2 @@
DIST hub-2.13.0.tar.gz 2074748 BLAKE2B e790c13cfab9070699b3995c91c3adfad89b438d70b4f0683dcf2f487349c785d97f1aa845620cf0ccabf93f6738a3a1d45410bd1155c861d55f3d2568312235 SHA512 77cc86948a4725a56b09eacdecb3227b46022de93f6ca8eb298441e32bda83cd8e6bb7874e029caae06852c6edcedfaa19382599d6f6ad9760663ff2573d2342
+DIST hub-2.14.1.tar.gz 2077137 BLAKE2B 35e209766e73979c6629c4542d405d0a724b2ec77d89ef14c50b7630118e55b8d4afc96d1dd7daadf6d790b55dae45b33a855ec49ac9ff87d347849874078ef0 SHA512 dc4fc1ea27c4338ace1233089eea45fe4b636d6b000ef49b2ae44481d508b76c4c2035573acb0654efb2a3986ebdeb7b57dee9e77bbbdedc319c6dbba4ea6f8c
diff --git a/dev-vcs/hub/hub-2.14.1.ebuild b/dev-vcs/hub/hub-2.14.1.ebuild
new file mode 100644
index 000000000000..02a51219754b
--- /dev/null
+++ b/dev-vcs/hub/hub-2.14.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="Command-line wrapper for git that makes you better at GitHub"
+HOMEPAGE="https://github.com/github/hub"
+SRC_URI="https://github.com/github/hub/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-vcs/git-1.7.3"
+
+src_compile() {
+ emake bin/hub man-pages
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin bin/${PN}
+ dodoc README.md
+ doman share/man/man1/*.1
+
+ newbashcomp etc/${PN}.bash_completion.sh ${PN}
+
+ insinto /usr/share/vim/vimfiles
+doins -r share/vim/vimfiles/*
+ insinto /usr/share/zsh/site-functions
+ newins etc/hub.zsh_completion _${PN}
+}