summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2019-11-27 13:46:07 -0600
committerWilliam Hubbs <williamh@gentoo.org>2019-11-27 13:46:07 -0600
commit2c377c14e55b4e92e36f27ab8d9e315488cab9a8 (patch)
tree08743b51269beb875d16f988c00fd38f056aa1dd /dev-vcs/python-gitlab/python-gitlab-1.13.0.ebuild
parentsys-kernel/genkernel: bump to v4.0.0_rc3 (diff)
downloadgentoo-2c377c14e55b4e92e36f27ab8d9e315488cab9a8.tar.gz
gentoo-2c377c14e55b4e92e36f27ab8d9e315488cab9a8.tar.bz2
gentoo-2c377c14e55b4e92e36f27ab8d9e315488cab9a8.zip
dev-vcs/python-gitlab: 1.13.0 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-vcs/python-gitlab/python-gitlab-1.13.0.ebuild')
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-1.13.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-vcs/python-gitlab/python-gitlab-1.13.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-1.13.0.ebuild
new file mode 100644
index 000000000000..2ee27c73fd03
--- /dev/null
+++ b/dev-vcs/python-gitlab/python-gitlab-1.13.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6} )
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Python command line interface to gitlab API"
+HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/testrepository[${PYTHON_USEDEP}]
+ dev-python/hacking[${PYTHON_USEDEP}]
+ dev-python/httmock[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.3
+ dev-python/sphinx_rtd_theme )"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r *.rst docs
+}