summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-06-18 09:38:49 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-06-18 09:39:33 -0500
commit7bb6401f769331465ffab39936eb3ea8981d3e9d (patch)
tree511f56daa4b7f8a4cd1384dc4ac2516780f130e3 /dev-vcs/python-gitlab/python-gitlab-2.3.1.ebuild
parentdev-perl/Class-Default: -r bump for EAPI7 (diff)
downloadgentoo-7bb6401f769331465ffab39936eb3ea8981d3e9d.tar.gz
gentoo-7bb6401f769331465ffab39936eb3ea8981d3e9d.tar.bz2
gentoo-7bb6401f769331465ffab39936eb3ea8981d3e9d.zip
dev-vcs/python-gitlab: 2.3.1 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-vcs/python-gitlab/python-gitlab-2.3.1.ebuild')
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-2.3.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-vcs/python-gitlab/python-gitlab-2.3.1.ebuild b/dev-vcs/python-gitlab/python-gitlab-2.3.1.ebuild
new file mode 100644
index 000000000000..fb687ff4c2f1
--- /dev/null
+++ b/dev-vcs/python-gitlab/python-gitlab-2.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Python command line interface to gitlab API"
+HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="test? (
+ dev-python/httmock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r *.rst docs
+}