summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-09-02 17:30:42 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-09-02 17:31:19 -0500
commit2bc481daeb2e241f5c39fb8e729b29666b2b760e (patch)
tree114f3041a8167280d58661f7730eed90c9954c9e /dev-vcs/python-gitlab
parentdev-libs/libfido2: bump to v1.5.0 (diff)
downloadgentoo-2bc481daeb2e241f5c39fb8e729b29666b2b760e.tar.gz
gentoo-2bc481daeb2e241f5c39fb8e729b29666b2b760e.tar.bz2
gentoo-2bc481daeb2e241f5c39fb8e729b29666b2b760e.zip
dev-vcs/python-gitlab: 2.5.0 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-vcs/python-gitlab')
-rw-r--r--dev-vcs/python-gitlab/Manifest1
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-2.5.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-vcs/python-gitlab/Manifest b/dev-vcs/python-gitlab/Manifest
index 01ffd51b0cf5..74cc5bbfc057 100644
--- a/dev-vcs/python-gitlab/Manifest
+++ b/dev-vcs/python-gitlab/Manifest
@@ -4,3 +4,4 @@ DIST python-gitlab-1.8.0.tar.gz 115603 BLAKE2B 8ebebc1735e5531b4f95d82122b6ecf78
DIST python-gitlab-1.9.0.tar.gz 116460 BLAKE2B f0a0d9679e4e742d966c678f8dcc6b2464e5ae8a013038221b3c484e6bb6ae23c166f82fec85c3560ebbce3cf80bc23657b1b906d8c6f284a64589545acdb035 SHA512 cb0d58896f55837f7088ab08551f2e9f9f82e8a04c19979a69bc042c95cdb2d04174dec49a236ddcf1344c50e9ffc6f929750b008bf6e619225c80bf9490afaa
DIST python-gitlab-2.2.0.tar.gz 136178 BLAKE2B 23f04638ba34f63048143e834342ea81e8a8cacdbc0502490543bc5b6de9fea6a58c884bc4111aea0fb27a343d22b9dfc62d5000b873ab90105f6aa5a80b7ff5 SHA512 bdf34e4b9e45f5767faf81d52caf1b800d931a105940bb80b1e58cc8efc34a319196a6aa437d49215f0f4ff24359cc2497853486698a23413b2bb3dfe169e5e3
DIST python-gitlab-2.3.1.tar.gz 142026 BLAKE2B 94bc2c65722fc83abb1793fc9b5eabcb3224ac9087af111c5865ffd0ee553f579187cf881b5dbc20536e6d7956a6c563b9e5ea4866dc4617639413a5e0075146 SHA512 2e48dfb025ca1645e78a3c5b4fa53085819dcffc916c43558a760a9471f08315249d0199d8db1740aba50e895762f48ffb19b1031e6204039229a48f5b93e447
+DIST python-gitlab-2.5.0.tar.gz 148916 BLAKE2B f870833a01adac08b71dc402bc11ba9c1be19c920735faf04de9bfca3b1a154706da4bc0475437997e3b03d8c9a56977a6691df05b750d64a1f8b964ecd05612 SHA512 7382f9ea2388c6916f3c7e63df137d73f0fdfb3890a8bbb47e766f3476b6febecd1dcbc588445ae1af1b5f17c9a3e6ed9a931fd9fff010c2c37967eab5440824
diff --git a/dev-vcs/python-gitlab/python-gitlab-2.5.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-2.5.0.ebuild
new file mode 100644
index 000000000000..fb687ff4c2f1
--- /dev/null
+++ b/dev-vcs/python-gitlab/python-gitlab-2.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Python command line interface to gitlab API"
+HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="test? (
+ dev-python/httmock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r *.rst docs
+}