summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-01-02 12:46:29 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-01-02 12:46:29 -0600
commit6e12f33d52e654193f79337ccbaf8d87b07cf2d2 (patch)
tree9bb501e208123c4020b72d0a4b233831927ff78c /dev-vcs/python-gitlab
parentdev-vcs/python-gitlab: disable py3.11 (diff)
downloadgentoo-6e12f33d52e654193f79337ccbaf8d87b07cf2d2.tar.gz
gentoo-6e12f33d52e654193f79337ccbaf8d87b07cf2d2.tar.bz2
gentoo-6e12f33d52e654193f79337ccbaf8d87b07cf2d2.zip
dev-vcs/python-gitlab: drop 3.5.0, 3.6.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-vcs/python-gitlab')
-rw-r--r--dev-vcs/python-gitlab/Manifest2
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-3.5.0.ebuild36
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-3.6.0.ebuild38
3 files changed, 0 insertions, 76 deletions
diff --git a/dev-vcs/python-gitlab/Manifest b/dev-vcs/python-gitlab/Manifest
index ba713aa5c9d3..65d19356ee97 100644
--- a/dev-vcs/python-gitlab/Manifest
+++ b/dev-vcs/python-gitlab/Manifest
@@ -1,4 +1,2 @@
DIST python-gitlab-3.10.0.tar.gz 254166 BLAKE2B 74b1a200e4ac1e99d5fc89b3906e8e623e3e7c210b0483e3947f24b882e61ce4ca9dafd43cfb047e4fa848c8970429ff0391db7c750d452db0ca4f5034bb772f SHA512 5dc0fbe826fe1a07833a8d443721e540b6b6e8c35cf100286b9a1a964f2f8b4faa34df2eff9888507c6ba1835857216a73084f860343a494eac9f1353a28f327
DIST python-gitlab-3.12.0.tar.gz 264005 BLAKE2B 64215b0c2950b1d238ff0e69e88de463ce2645d7c3911963e516b50874b49c4e822f8e27625fa33e6d27a703cc3bb3377151a9bc9c49b0b49ee7bc57db5dfd65 SHA512 76f55945a821553b4b477629dea674956459836df227e70817480b031559317ec97fef6c332d0dc42c4dba0d556ed1118e1cded8f116f4813bebe411db9e7a47
-DIST python-gitlab-3.5.0.tar.gz 225751 BLAKE2B 25efd5de5addde6cdb19307217080213e8f0aa9b189307fe10fb9af55d8db92752794cf71c3e826629f043dd85d6078dbf9e96418d3e96d38209a5a81629d589 SHA512 fdc719f0cb0bf588390f0f6f0ffc4814bb5135156ecbe96cb4b381a7f93606a49773d1e8a34397a0f3b4522c8867704429070bae7bec6cf34b9e713f0a9c9189
-DIST python-gitlab-3.6.0.tar.gz 235738 BLAKE2B 4ed26f2d8add0fbfdc52bd8d7f61e06b717a2f8b7995b8c75eaf67a20362c259d0c487177ba695310cff11bb0129e49cb3c0058682488da9b8f61b477c4a07f1 SHA512 b2fe2dd62b76929d3acef0c8fc815b91ac5949af47fa43110d461d541ecd943af2e3c7afc94ad4b396b8d8815b4201a65ef7199bf886f5e5b0419b3d9bff2575
diff --git a/dev-vcs/python-gitlab/python-gitlab-3.5.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-3.5.0.ebuild
deleted file mode 100644
index 90eec639d832..000000000000
--- a/dev-vcs/python-gitlab/python-gitlab-3.5.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{8,9,10} )
-inherit distutils-r1
-
-DESCRIPTION="Python command line interface to gitlab API"
-HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="LGPL-3"
-SLOT="0"
-
-BDEPEND="test? (
- dev-python/httmock[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- )"
-
-RDEPEND=">=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
- >=dev-python/requests-toolbelt-0.9.1[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-python_install_all() {
- distutils-r1_python_install_all
- dodoc -r *.rst docs
-}
diff --git a/dev-vcs/python-gitlab/python-gitlab-3.6.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-3.6.0.ebuild
deleted file mode 100644
index ceaf08012a3d..000000000000
--- a/dev-vcs/python-gitlab/python-gitlab-3.6.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{8,9,10} )
-inherit distutils-r1
-
-DESCRIPTION="Python command line interface to gitlab API"
-HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="LGPL-3"
-SLOT="0"
-
-BDEPEND="test? (
-dev-python/coverage[${PYTHON_USEDEP}]
->=dev-python/pytest-console-scripts-1.3.1[${PYTHON_USEDEP}]
-dev-python/pytest-cov[${PYTHON_USEDEP}]
->=dev-python/pyyaml-5.2[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- )"
-
-RDEPEND=">=dev-python/requests-2.28.1[${PYTHON_USEDEP}]
- >=dev-python/requests-toolbelt-0.9.1[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-python_install_all() {
- distutils-r1_python_install_all
- dodoc -r *.rst docs
-}