summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-01-02 13:18:42 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-01-02 13:19:20 -0600
commit7fcbad1ddcac8478e7151b5df4b964374923f034 (patch)
treec2c9c3a4a627b1ebf6ae98241083cc5b3d68183b /dev-vcs/python-gitlab
parentsci-libs/dealii: fix missing dependency on sci-mathematics/cgal (diff)
downloadgentoo-7fcbad1ddcac8478e7151b5df4b964374923f034.tar.gz
gentoo-7fcbad1ddcac8478e7151b5df4b964374923f034.tar.bz2
gentoo-7fcbad1ddcac8478e7151b5df4b964374923f034.zip
dev-vcs/python-gitlab: pkgcheck fixes
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-vcs/python-gitlab')
-rw-r--r--dev-vcs/python-gitlab/metadata.xml7
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-3.10.0.ebuild3
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-vcs/python-gitlab/metadata.xml b/dev-vcs/python-gitlab/metadata.xml
index db463f3eeb66..d731c9ba2ef3 100644
--- a/dev-vcs/python-gitlab/metadata.xml
+++ b/dev-vcs/python-gitlab/metadata.xml
@@ -4,5 +4,10 @@
<maintainer type="person">
<email>williamh@gentoo.org</email>
<name>William Hubbs</name>
- </maintainer>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">python-gitlab/python-gitlab</remote-id>
+ <remote-id type="pypi">python-gitlab</remote-id>
+ <bugs-to>https://github.com/python-gitlab/python-gitlab/issues</bugs-to>
+ </upstream>
</pkgmetadata>
diff --git a/dev-vcs/python-gitlab/python-gitlab-3.10.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-3.10.0.ebuild
index 88e18c0203c2..4e3c85bdff4a 100644
--- a/dev-vcs/python-gitlab/python-gitlab-3.10.0.ebuild
+++ b/dev-vcs/python-gitlab/python-gitlab-3.10.0.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8,9,10} )
inherit distutils-r1