summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2017-04-22 21:05:55 +0200
committerDavide Pesavento <pesa@gentoo.org>2017-04-22 21:06:19 +0200
commit7a297d8b8d313a36f9356463122f4b59e560b49a (patch)
treeef02f8359e5e90afe88807d68f63697f2253ee49 /dev-vcs/qgit/qgit-2.7.ebuild
parentsys-process/tini: activate static use flag by default to fix docker (diff)
downloadgentoo-7a297d8b8d313a36f9356463122f4b59e560b49a.tar.gz
gentoo-7a297d8b8d313a36f9356463122f4b59e560b49a.tar.bz2
gentoo-7a297d8b8d313a36f9356463122f4b59e560b49a.zip
dev-vcs/qgit: version bump
Switched to cmake, as the qmake-based buildsystem is broken in multiple ways. Gentoo-Bug: 612390 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-vcs/qgit/qgit-2.7.ebuild')
-rw-r--r--dev-vcs/qgit/qgit-2.7.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-vcs/qgit/qgit-2.7.ebuild b/dev-vcs/qgit/qgit-2.7.ebuild
new file mode 100644
index 000000000000..5dc7e20ae956
--- /dev/null
+++ b/dev-vcs/qgit/qgit-2.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Qt GUI for git repositories"
+HOMEPAGE="http://libre.tibirna.org/projects/qgit"
+SRC_URI="https://github.com/tibirna/qgit/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}
+ dev-vcs/git
+ !dev-vcs/qgit:2
+"
+
+S=${WORKDIR}/${PN}-${P}