summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/rabbitvcs/rabbitvcs-0.15.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/rabbitvcs/rabbitvcs-0.15.3.ebuild')
-rw-r--r--dev-vcs/rabbitvcs/rabbitvcs-0.15.3.ebuild94
1 files changed, 94 insertions, 0 deletions
diff --git a/dev-vcs/rabbitvcs/rabbitvcs-0.15.3.ebuild b/dev-vcs/rabbitvcs/rabbitvcs-0.15.3.ebuild
new file mode 100644
index 000000000000..5f24d042a764
--- /dev/null
+++ b/dev-vcs/rabbitvcs/rabbitvcs-0.15.3.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.7"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit eutils gnome2-utils multilib distutils
+
+DESCRIPTION="Integrated version control support for your desktop"
+HOMEPAGE="http://rabbitvcs.org"
+SRC_URI="http://rabbitvcs.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cli diff gedit git nautilus spell thunar"
+
+RDEPEND="dev-python/configobj
+ dev-python/pygobject:2
+ dev-python/pygtk
+ dev-python/pysvn
+ dev-python/simplejson
+ diff? ( dev-util/meld )
+ gedit? ( app-editors/gedit )
+ git? ( dev-python/dulwich )
+ nautilus? ( >=dev-python/nautilus-python-0.7.0
+ dev-python/dbus-python
+ dev-python/gnome-vfs-python )
+ spell? ( dev-python/gtkspell-python )
+ thunar? ( dev-python/thunarx-python
+ dev-python/dbus-python )"
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+
+ distutils_src_prepare
+
+ # we should not do gtk-update-icon-cache from setup script
+ # we prefer portage for that
+ sed -e 's/"install"/"fakeinstall"/' -i "${S}/setup.py" || die
+}
+
+src_install() {
+ distutils_src_install
+
+ if use cli ; then
+ dobin clients/cli/${PN}
+ fi
+ if use gedit ; then
+ insinto /usr/$(get_libdir)/gedit-2/plugins
+ doins clients/gedit/${PN}-plugin.py
+ doins clients/gedit/${PN}-gedit2.gedit-plugin
+ insinto /usr/$(get_libdir)/gedit/plugins
+ doins clients/gedit/${PN}-plugin.py
+ doins clients/gedit/${PN}-gedit3.plugin
+ fi
+ if use nautilus ; then
+ insinto /usr/$(get_libdir)/nautilus/extensions-2.0/python
+ doins clients/nautilus/RabbitVCS.py
+ insinto /usr/share/nautilus-python/extensions
+ doins clients/nautilus-3.0/RabbitVCS.py
+ fi
+ if use thunar ; then
+ insinto "/usr/$(get_libdir)/thunarx-2/python"
+ doins clients/thunar/RabbitVCS.py
+ insinto "/usr/$(get_libdir)/thunarx-1/python"
+ doins clients/thunar/RabbitVCS.py
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ gnome2_icon_cache_update
+
+ elog "You should restart file manager to changes take effect:"
+ use nautilus && elog "\$ nautilus -q"
+ use thunar && elog "\$ thunar -q && thunar &"
+ elog ""
+ elog "Also you should really look at known issues page:"
+ elog "http://wiki.rabbitvcs.org/wiki/support/known-issues"
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ gnome2_icon_cache_update
+}