summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2019-11-18 02:49:58 -0500
committerMike Frysinger <vapier@gentoo.org>2019-11-18 02:52:19 -0500
commitc97a381152cc54d1c11d1478f000d2c487f724e3 (patch)
tree2ea29337f349d18e2f353426a2d198dd31e7ae56 /dev-vcs/repo/repo-1.26.ebuild
parentpackage.mask: Last rite for media-libs/skstream (diff)
downloadgentoo-c97a381152cc54d1c11d1478f000d2c487f724e3.tar.gz
gentoo-c97a381152cc54d1c11d1478f000d2c487f724e3.tar.bz2
gentoo-c97a381152cc54d1c11d1478f000d2c487f724e3.zip
dev-vcs/repo: moved & updated from dev-util/repo
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'dev-vcs/repo/repo-1.26.ebuild')
-rw-r--r--dev-vcs/repo/repo-1.26.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-vcs/repo/repo-1.26.ebuild b/dev-vcs/repo/repo-1.26.ebuild
new file mode 100644
index 000000000000..d1563fd6addb
--- /dev/null
+++ b/dev-vcs/repo/repo-1.26.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NB: The $PV tracks the *repo launcher version*, not the last signed release
+# of the repo project. They are confusingly different currently.
+
+EAPI="7"
+
+PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} )
+
+inherit python-r1
+
+DESCRIPTION="Google tool for managing git, particularly multiple repos"
+HOMEPAGE="https://gerrit.googlesource.com/git-repo"
+SRC_URI="https://storage.googleapis.com/git-repo-downloads/${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-admin/radmind
+ !dev-util/repo"
+
+S=${WORKDIR}
+
+src_install() {
+ python_foreach_impl python_newscript "${DISTDIR}/${P}" ${PN}
+}