summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2022-11-24 15:18:00 +0900
committerMike Frysinger <vapier@gentoo.org>2022-11-24 15:18:59 +0900
commit87658817c275bb8b2ceab0668ecd1cacb89d16ae (patch)
treed4a9525f6d3575645c6e6900ab130d640e5d31a6 /dev-vcs/repo
parentdev-vcs/repo: drop old 2.21 version (diff)
downloadgentoo-87658817c275bb8b2ceab0668ecd1cacb89d16ae.tar.gz
gentoo-87658817c275bb8b2ceab0668ecd1cacb89d16ae.tar.bz2
gentoo-87658817c275bb8b2ceab0668ecd1cacb89d16ae.zip
dev-vcs/repo: version bump to 2.30
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'dev-vcs/repo')
-rw-r--r--dev-vcs/repo/Manifest2
-rw-r--r--dev-vcs/repo/repo-2.30.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-vcs/repo/Manifest b/dev-vcs/repo/Manifest
index dff3c2c6a541..70a20a984897 100644
--- a/dev-vcs/repo/Manifest
+++ b/dev-vcs/repo/Manifest
@@ -1 +1,3 @@
DIST repo-2.29.tar.gz 248253 BLAKE2B 6b51a0416634eab52f44410fe156c736a6c69234345b4cf5115692a9b56d479c0bce780583fb2ee6b9ca206e5163adbf6ded85ff5d7f2b174a7e7cd6dc37dd57 SHA512 7323b52709164999a80172bc39398ad9989c3eb97bcfda66a675c3f94792cdd742068d47bbcc66dc8fffbe3b661c2fb19332a72a7f889a249f73fa448fcb32d1
+DIST repo-2.30 45769 BLAKE2B 46e8f37b138f1ebfa3109962f2690cc3bc6c38a2dd4333cd5be6fc1168476945cbd73f142486141a00552b8a998d4a765e54fce605d1872a670a3043fb213b05 SHA512 e8ad4e35417992f15bfa081ce282e1e518dcb885c04176f18ff2859ccb1dd397087224980f441020be12083c9847fcce661370119fe08f17be04718eff4a7a96
+DIST repo-2.30.tar.gz 252945 BLAKE2B ebaadc1f624941139c14417e86e1a4960fbba9da7b9053bab8f2cb1647c40a6f1f63951bcbb6d9162803066f9b05d1fb469e82b7d3b2bea31215b97b1bddf84f SHA512 7d184605e8d8e30bc48a4d3f2345c7ee9a8075711729108b5d487242c9311dc1cf22595f9ba09192a28460d6127e8cbe96a70fcdaf7c6baeb1e26a8ac15a7cae
diff --git a/dev-vcs/repo/repo-2.30.ebuild b/dev-vcs/repo/repo-2.30.ebuild
new file mode 100644
index 000000000000..1eaf21021d74
--- /dev/null
+++ b/dev-vcs/repo/repo-2.30.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NB: The ${PV} tracks the *repo launcher version*, not the last signed release
+# of the repo project. The launcher only gets a new update when changes are
+# made in it.
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit bash-completion-r1 python-r1
+
+DESCRIPTION="Google tool for managing git, particularly multiple repos"
+HOMEPAGE="https://gerrit.googlesource.com/git-repo"
+SRC_URI="https://storage.googleapis.com/git-repo-downloads/${P}
+ https://github.com/GerritCodeReview/git-repo/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-admin/radmind
+ !dev-util/repo"
+
+S="${WORKDIR}/git-${P}"
+
+src_install() {
+ python_foreach_impl python_newscript "${DISTDIR}/${P}" ${PN}
+ newbashcomp completion.bash ${PN}
+ doman man/*.[0-9]
+}