summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/statsvn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/statsvn')
-rw-r--r--dev-vcs/statsvn/Manifest1
-rw-r--r--dev-vcs/statsvn/files/statsvn-0.4.1-build.xml.patch19
-rw-r--r--dev-vcs/statsvn/metadata.xml11
-rw-r--r--dev-vcs/statsvn/statsvn-0.5.0.ebuild73
4 files changed, 104 insertions, 0 deletions
diff --git a/dev-vcs/statsvn/Manifest b/dev-vcs/statsvn/Manifest
new file mode 100644
index 000000000000..db064084841b
--- /dev/null
+++ b/dev-vcs/statsvn/Manifest
@@ -0,0 +1 @@
+DIST statsvn-0.5.0-source.zip 14686488 SHA256 af9f36d364a6a348b50ffc5f248fafee5292cde1e39eccc08b8f1b038736e275 SHA512 0f723659ede09ca3770354c8da7ca94237e01068e7743b4bfa3dfcf50d21d04130ad219b0a40f2fcffece85c2c9e9444d7b2e9de7f2048b935223c09864d3cbf WHIRLPOOL 5206d6d946e4d33a6df082f5f527d3af289757e9e970773f537d279f0f610b20f3e789c27e396e93a99917b7aa9ca3c848e6baa8e8e92fe85cdb4e5b1b54c4eb
diff --git a/dev-vcs/statsvn/files/statsvn-0.4.1-build.xml.patch b/dev-vcs/statsvn/files/statsvn-0.4.1-build.xml.patch
new file mode 100644
index 000000000000..48c050eb25db
--- /dev/null
+++ b/dev-vcs/statsvn/files/statsvn-0.4.1-build.xml.patch
@@ -0,0 +1,19 @@
+diff -Nur statsvn-0.4.1/build.xml statsvn-0.4.1_patched/build.xml
+--- statsvn-0.4.1/build.xml 2007-03-14 03:33:20.000000000 +0200
++++ statsvn-0.4.1_patched/build.xml 2008-09-19 05:45:40.000000000 +0300
+@@ -130,15 +130,6 @@
+ </target>
+
+ <target name="dist" depends="compile,copyfiles">
+- <!-- Creates an executable jar file for the project -->
+- <unjar src="${lib}/${statcvs.jar}" dest="${build}" />
+- <!-- Expand and use the concurrent JAR -->
+- <unjar src="${lib}/${concurrent.jar}" dest="${build}" />
+-
+- <!-- Now included in statcvs.jar -->
+- <!--<unjar src="${lib}/${jfreechart.jar}" dest="${build}" />
+- <unjar src="${lib}/${jcommon.jar}" dest="${build}" />-->
+-
+ <mkdir dir="${dist}" />
+ <jar jarfile="${dist}/${project.jar}" basedir="${build}">
+ <manifest>
diff --git a/dev-vcs/statsvn/metadata.xml b/dev-vcs/statsvn/metadata.xml
new file mode 100644
index 000000000000..e927a7d48597
--- /dev/null
+++ b/dev-vcs/statsvn/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <maintainer>
+ <email>java@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">statsvn</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-vcs/statsvn/statsvn-0.5.0.ebuild b/dev-vcs/statsvn/statsvn-0.5.0.ebuild
new file mode 100644
index 000000000000..a96812d2e95f
--- /dev/null
+++ b/dev-vcs/statsvn/statsvn-0.5.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+JAVA_PKG_IUSE="doc source test"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="StatSVN generates HTML reports from SVN repository logs"
+HOMEPAGE="http://www.statsvn.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-source.zip"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+COMMON_DEPEND="
+ >=dev-vcs/statcvs-0.5:0
+ >=dev-java/backport-util-concurrent-3.1:0
+ dev-java/jcommon:1.0
+ dev-java/jfreechart:1.0"
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ test? ( dev-java/junit:0 )
+ ${COMMON_DEPEND}"
+
+RDEPEND=">=virtual/jre-1.4
+ >=dev-vcs/subversion-1.3.0
+ dev-java/xerces:2
+ ${COMMON_DEPEND}"
+
+EANT_GENTOO_CLASSPATH="statcvs,backport-util-concurrent,jcommon-1.0,jfreechart-1.0"
+EANT_BUILD_TARGET="dist"
+JAVA_ANT_CLASSPATH_TAGS="javac java javadoc"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+java_prepare() {
+ ebegin "Removing bundled jars."
+ find . -name "*.jar" -delete
+ eend
+ ebegin "Removing prebuilt classses."
+ find . -name "*.class" -delete
+ rm -r "${S}"/bin/*
+ eend
+ epatch "${FILESDIR}"/${PN}-0.4.1-build.xml.patch
+}
+
+src_test() {
+ ewarn "Note that the tests require you to be online."
+ eant -Dgentoo.classpath=$(java-pkg_getjars ${EANT_GENTOO_CLASSPATH}):$(java-pkg_getjars --build-only junit) test
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+
+ # jfreechart pulls in gnu-jaxp which doesn't work for statsvn so we need
+ # to force another SAXParserFactory and DocumentBuilderFactory
+ java-pkg_register-dependency xerces-2
+ java-pkg_dolauncher statsvn --main net.sf.statsvn.Main \
+ --java_args '-Djavax.xml.parsers.SAXParserFactory=org.apache.xerces.jaxp.SAXParserFactoryImpl -Djavax.xml.parsers.DocumentBuilderFactory=org.apache.xerces.jaxp.DocumentBuilderFactoryImpl'
+
+ use doc && java-pkg_dojavadoc doc
+ use source && java-pkg_dosrc src/*
+}
+
+pkg_postinst() {
+ elog "For instractions on how to use StatSVN see"
+ elog "http://svn.statsvn.org/statsvnwiki/index.php/Main_Page"
+ elog "You need to regenerate statistics"
+ elog "if you update dev-java/jtreemap"
+}